How to disable first run portal

  • Ubuntu 12.04
    Opera 12.16

    I'm using Opera in kiosk mode but each time it starts it always takes you to the first run startup portal page instead of the designated home page. Behind that page is the famous:

    "It appears another Opera instance is using the same configuration directory because its lock file is active
    /home/"your profile"/.opera/lock
    Do you want to start Opera anyway?"

    After I close the portal first run startup page and click Yes my designated home page loads. I've tried uninstalling opera and deleting the .opera folder for the profile and then doing a clean install. I'm not using the option in preferences to retain last opened pages. Is there a switch to disable the first run portal redirect?

    Note: I have searched far and wide for an answer to this problem but seem to get only old forum links that do not exist any more. Can you also populate your new forum with your old KB info?

  • There is an option in opera:config (or in the file operaprefs.ini) to tell it the first run page has already been displayed. Or just run it without kioskmode once (and without the lockfile) so that it will set that option itself.

  • You should find some useful settings for use with Opera 12’s Kiosk mode in testacular’s old Opera.js launcher.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.