Unread mail in Inbox

  • I have recently changed from Opera 12 to Opera 29 and OperaMail.

    I have noticed that some incoming messages are delivered into the Received label, but others only appear in Inbox (as well as under Unread). They do not appear under any other label.

    How can I get all messages to start in Received?

  • Click the "settings for this view" button above the Received message list. There you can adjust the show settings. For example, if the message is automatically filtered into a label that has "Hide these messages from other views" set, you'll need to check "show hidden" for Received.

  • Hi burnout, thanks for replying.

    I do not see a button labelled "settings for this view". I've tried right-clicking Received but there seems to be nothing useful there either. "Properties"is greyed out at all times. I've tried clicking all the settings buttons, but nothing seems relevant. I have not seen a "show hidden" setting anywhere.

    I do not automatically filter messages into labels and anyway, no labels show unread messages - only the Unread label and Inbox do. However, labels do have "hide from other views" ticked.

  • I do not see a button labelled "settings for this view"

    When you left-click on "All Messages/Received" to open its message list, there will be a toolbar above the message list. On that toolbar will be a button. That button is a vertical (not slanted) wrench with horizontal lines on the left of the wrench and a drop-down arrow on the right of that wrench. You need to left-click it.

    If you still don't see the button, right-click on that toolbar, goto customize and reset the toolbar to its defaults.

    I do not automatically filter messages into labels and anyway, no labels show unread messages - only the Unread label and Inbox do. However, labels do have "hide from other views" ticked.

    If setting "show hidden" and such for "All Messages/Received" doesn't help, there may be some other issue like corruption.

  • Thanks burnout426. The messages were under the Mailing Lists label, which never shows in bold - but now that I know where to look, I notice it has the number of those missing unread mails next to it.

    As these are not my mailing lists but someone else's, how can I make them appear as unread mails?

  • As these are not my mailing lists but someone else's, how can I make them appear as unread mails?

    I think all you can do is check "mailing lists" under the "show" settings for the Unread message list.

    Not sure why unread messages in the mailing list view for that list are not shown in bold though. There should be an unread count next to that mailing list also.

  • The count is there, but it was not bolded (today no emails arrived in mailing lists). At least I'll now where to look now.

    I did notice something new though. Two emails (1 yesterday and 1 today) stay in received after I drop them on a label, even though all other similar emails are invisible in Received (the label is set to "hide messages from other views"). Any guesses?

  • I did notice something new though. Two emails (1 yesterday and 1 today) stay in received after I drop them on a label, even though all other similar emails are invisible in Received (the label is set to "hide messages from other views"). Any guesses?

    I'd check the database to see if that fixes anything. There could be some corruption.

    To rule out more corruption, you could also recreate all your labels (you can add duplicates with the same name). Then, drag the messages from the old copy of the label to the new copy of the label. Then, delete the old copy of the label. Do that for each label.

    For the mailing list entry, you can delete the mailing list. The messages will still remain. The mailing list will be recreated next time a message for it comes in.

    If you want all of those messages in the labels to show in Received, check "show hidden" for Received.

  • Thanks again, burnout. I had forgotten that I had turned "show hidden" on after one of your early posts. Turning it back off made those messages disappear. I only have a couple of labels and most messages just stay in received, so it was only obvious with the last couple of labelled messages.

    Apart from those pesky mailing lists, all seems to be under control now.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.