Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flash Video Keeps Pausing ("Skipping") But NOT the Audio

  • I am seeing it also

    Flash Player 17.0.0.169

  • @chas4 do you get the same problem if you switch to HTML5 video? (You can switch here https://www.youtube.com/html5?gl=GB)

    What version of OX X are you running? (I'm on Yosemite 10.10.3)

  • Could you check what Flash type are you using.
    Go to opera:plugins, Click on Show Details button, and look for Adobe Flash.
    Check if you have PPAPI or NPAPI plugin installed.
    If you don't have PPAPI installed, I would advise you to do so, this is working much better 🙂

  • @rrzepecki the problem isn't directly related to Flash. I have You Tube set to use HTML5 video and I still get the pauses in the video display.

  • I experience the same problems here. Using PPAPI Flash.
    Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.82 Safari/537.36 OPR/29.0.1795.41 (Edition beta)

    I've found this in Console.app:
    05.05.2015 19:12:34,000 kernel[0]: process Opera Helper[47903] caught causing excessive wakeups. Observed wakeups rate (per sec): 197; Maximum permitted wakeups rate (per sec): 150; Observation period: 300 seconds; Task lifetime number of wakeups: 45002
    When I open Opera's task manager, then main browser process peaks 40% every few seconds, even though I'm not doing anything.

    This suggests it's the same problems I reported to you a long time ago, but it disappeared. Now it's there again. It drains my battery:(

  • @mbaluta do the OS X console log timings tie up with the pauses in the video for you? When I checked the logs as I viewed pages on You Tube, the no new entries were added. I do however see similar lines to the ones you've highlighted at other times.

    Why do you think process wakups would cause the video display to pause?

  • I am using Opera 29.0.1795.47

    My problem is similar - the video pauses every 10 - 12 seconds, but the audio continues.
    This effect is not limited to videos - it happens even when browsing. There is an irritating hesitation or jerking of the display every 10 seconds.
    This does NOT happen with other browsers - it is only with Opera

    I have been using this browser for years; and it's my default on all the systems I use - Linux, Windows and MacBook Air (I have not yet tried it on the iPad or iPhone)

    My Opera version is up-to-date; and I'm sure the problem lies with Opera, not with any other browsers.
    How do we report this to the Opera guys?

  • The Opera bug reporter is here https://bugs.opera.com/wizarddesktop/

  • I've got a possible workaround.

    Quit Opera and go to ~/Library/Application Support/com.operasoftware.Opera/
    Rename the files session.db, session-db.journal, session.dbak
    Restart Opera and it will re-create those files.

    Anything I watch on You Tube now diplays fine. It looks to me as though Opera have done something screwy with their tab/session handling that causes a lag every few seconds.

    I don't consider this a long-term fix for me as I want to keep the details of all the 30+ tabs I currently have open so I've had to rename these files back. However if it fixes the problem for others, it does point to the problem being with the session/tab database. (In the meantime, I'm back to watching any video in Safari 😞 )

  • I think it's better for me after upgrade to Opera 30:)