Is there an older version of Opera that I can use on a MacBook running OS X 10.6.8?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.