Opera 12.16 (ubuntu) target="_blank" links opening in background

  • Well, I managed to mess my Opera configuration. Or it was the cat walking on my keyboard, I don't know. Anyway, the problem is that the target="_blank" links are opening in a background tab.

    Actually, the first problem that I noticed was that the target="_blank" tag was not obeyed at all. After some digging I noticed that "Ignore Target" was enabled in "opera:config". So, I disabled it, and the links with this tag started to open in a new tab. However, it opens in the background. This is driving me nuts... Any suggestions how to make the new tab appear in the foreground by default are welcome.

    Thanks!

  • On what site does this happen or did you make your own testcase? It could be a background popup script at work.

  • I managed to fix it. Obviously, the morning is smarter than the evening. I had to change:

    opera:config -> User Prefs -> Target Destination from "2" to "0"

    It was happening on all pages. I've configured Google to open results in new pages. That's how I noticed it first. However, it was not the sites, but my own config...

  • Depending on settings, Opera (Presto-based versions) can even force target links to open in the current window, or block them as pop-ups. No surprise there ...

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.