Opera 27: YouTube not working

  • So I recently upgraded from Opera 12 to Opera 27 (latest stable build with the most recent update). I love the browser but I tried YouTube for the first time last night and the browser failed to handle the site. The video loaded and the video timer started ticking but then the video image froze and refused to play. I refreshed the page a few times and it happened every time. I have updated to the latest Opera 27-compatible flash version from the flash website.

    This however should be irrelevant because YouTube now uses HTML5. Help?

    PS: It's also worth noting that the latest version of Firefox handles YouTube perfectly on this machine.

  • Do you have Opera Turbo enabled? Open the Opera menu and look near the bottom of the menu. Is there a check mark next to Opera Turbo?

  • When I tried youtube it was very slow inside opera 27 and the sound did not sync either

    Anyone else seen this?

  • When I tried youtube it was very slow inside opera 27 and the sound did not sync either
    Anyone else seen this?

    Flash or html5? Html5 videos were looking strange here, i emptied the cache and it seems better now.

  • How can I tell if using flash or HTML5? think its flash but not sure?

    Help appreciated Leo... as its spoiling my enjoyment of Opera 27 with Youtube 🙂

  • How can I tell if using flash or HTML5? think its flash but not sure?

    Right click on the video.

  • When I right click it says "about adobe flash player 16

    So I assume I am using flash player - what do I do? is there something else in settings?

    ?????

  • Had a look in YOUTUBE settings but cant find anything?

    Must be something better than flash?

  • Make sure your flash player version ends with 305, which is the latest one. Also check if you are using ppapi flash (you can verify it at opera:plugins).

    Also try empty the cache and also your OS %temp% folder.

  • OK had a look in plug ins and the only thing I can find was flash 16.0.0305 is that what you mean?

    What is ppapi flash? its not there

    helps appreciated

    pete

  • What is ppapi flash? its not there

    It's a new plugin architecture. Go to http://get.adobe.com/flashplayer/ using Opera and download it. Don't forget to uncheck the "optional offer".

  • Thanks Leo got new flash player - seemed to be the same one? As it mentioned Opera Downloaded it and installed it

    Seems to be less video stutter pauses but still some and the voice does not sync?

    Is that the best available?

  • seemed to be the same one? As it mentioned Opera Downloaded it and installed it

    You said you only have the npapi one and Opera should download the ppapi version.

    Seems to be less video stutter pauses but still some and the voice does not sync?

    I've been noticed some issues with flash player recently. Don't know if it's a plugin issue, an Opera issue or what.

    Is that the best available?

    Don't know if the best but it's basically the only one as support for npapi is being dropped by Chromium.

  • remember to clear your cache

  • Cleared the cache and tried again on www.ted.com still delay and speach out of sync with the picture

    Went on site and downloaded from the area where it said Opera - installed - no difference

    How can I see whats going on and what flash I am using?

  • Thanks for the link Lando .... it looks like I have the latest version 305 installed

    But its still rubbish!

    Can I do anything?

  • it looks like I have the latest version 305 installed

    It's the ppapi/pepper one? It looks better if you use the html5 player?

  • Leo, dont understand was told that 305 was the ppapi version - is there any difference? If so where do I get it from?

    HTML5 can Youtube use this? if so and its better how do I set it up - looked in youtube and cant find anything? If I right click on the image it seems to show I am using flash

    Really confused - is someone can help so I get the best experience in Youtube would appreciate it

    Thanks for all your help

    pete

  • Leo, dont understand was told that 305 was the ppapi version - is there any difference? If so where do I get it from?

    Afaik both npapi and ppapi are in the same version number, or very close at least.

    You should be able to get the ppapi version at https://get.adobe.com/flashplayer/

    HTML5 can Youtube use this? if so and its better how do I set it up - looked in youtube and cant find anything?

    You need to enable the html5 player at https://www.youtube.com/html5

    Note that some videos may not be played in the html5 player.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.