Does not open external links when default browser.

  • If I have a web address such as http://www.tldp.org/LDP/abs/html/ in gnote or another
    application clicking on this will open it in the default browser.
    This will work when the default browser is set to firefox, google-chrome, chromium, opera 12.16, or midori.

    When the default browser is set to opera-developer (Version:28.0.1750.11) it just opens a blank tab.

  • I tried to reproduce your problem. For me, it works in Opera stable (27). But when i tried it with opera-developer as default browser I also got a problem, but not exactly as you describe it. In opera-developer it opens, but not in an active tab. In opera stable though, it opens in an active tab.

  • Thanks for the feed back.
    Created a new Ubuntu user account and works there.
    Back in my usual account, renamed my ~/.config/opera-developerfolder, so as at next start opera-developer will load using the default config.
    Still just opens a blank tab.

    So opera-developer appears to be OK and it's some other setting in my normal user account.

  • Found what was wrong.
    I had made a custom launcher @ ~/.local/share/applications/opera-developer.desktop with an exec line.....
    Exec=opera-developer ....Seems the %U is needed.
    eg Exec=opera-developer %U

    When opera-developer is not open the link opens in background but if already open the new window opens in foreground.
    I'll work on that but at least it's opening.

  • 42.0.2374.0


    opera.exe - Точка входа не найдена

    Точка входа в процедуру SymGetSearchPathW не найдена в библиотеке DLL C:\Program Files (x86)\Opera Developer\42.0.2374.0\opera.dll.

    ОК

  • @denser-ru wrong forum (this forum is Opera for Linux, not Windows) and wrong language (this area is English).

  • Sorry, i get this thread by googling. Really hurt this bug.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.