Youtube Resolution Problem

  • Hi guys,

    Recently I found a problem with my Opera browser. When I watch video on Youtube, I found that I'm no longer be able to select resolution by clicking the gear graphic on status bar. When I click it, it only shows 360p and auto, no higher resolution is there. I'm sure those videos offer HD options since I've seen them before and I also tried a dozen of HD videos which still showed 360p format only.

    I tested it with other browser by pasting the same web address and it worked great with Google Chrome and IE so I'm pretty sure it's my opera's problem. This issue only happened on my laptop cuz I don't have the same issue on my PC. That's really weird...

    Can anybody help me and tell me what's wrong with it? Thanks a lot!!

  • i have the same problem with Opera Next 17.0
    i've tried some plugins, like Magic Actions for Youtube to set video quality to maximum, but it didn't helped either.
    also, this problem is not present on pre-Chromium Opera.

  • I also see the problem on Opera 17 now.

  • Opera Next 18 now, still the same.

  • Thanks for your feedback here.

    I'm running Opera 17.0.1241.45. So it seems that I'm not alone. This is a software problem. This is annoying because sometimes I'll project my laptop screen to TV and enjoy Youtube video for the entire night. Those video with 360/480p resolution really hurt my eye and waste the 50" flat TV.

    I think I should file a bug report for this issue...

  • i think i found the problem: HTML5 Youtube player. SRWare Iron and old Opera uses Flash player, so there's no such problem.
    untill that problem solved, i would like to know if there's a possibility to turn off HTML5 for youtube or completely, so i can watch Youtube normally.

  • happy I see this, nearly pulled my hair out searching for the cause of the problem.
    I'm getting really sick and tired of the buggy Opera. It's again like it was on previous presto based builds.
    Granted, dev channel can have issues, but now O18 has been released on the Next channel there is no excuse.

    I've tried hopping on the HTML5 youtube test and off again - No change.
    The resolution is always at 360p and cannot be set higher, even if the video itself offers 720p or 1080p.
    I use Internet Download Manager to download the video, and it correctly lets me choose from all available resolutions.

    Please some comment from any Opera dev? Will this be fixed anytime soon?

    Cheers.

    Edit:
    OK got it going now. For those with the HTML5 mess, do this:

    Right click on the video and choose "about HTML5" or something.
    You will be asked to join the HTML5 Trial. If you are not on the trial, JOIN FIRST.
    After that, LEAVE the trial.
    If you are already on the trial, just choose LEAVE.

    In Opera, choose settings-Privacy and Security-Clear browsing data.
    Close Opera, and open it again.
    Play a video - Opera will now use Flash player.

    I just saw that Chrome users also have these issues, and that's something that Opera is "inheriting" from using the same engine.

  • Originally posted by Alacran:

    Right click on the video and choose "about HTML5" or something.
    You will be asked to join the HTML5 Trial. If you are not on the trial, JOIN FIRST.
    After that, LEAVE the trial.
    If you are already on the trial, just choose LEAVE.

    In Opera, choose settings-Privacy and Security-Clear browsing data.
    Close Opera, and open it again.

    that worked, thanks!

  • Originally posted by Alacran:

    happy I see this, nearly pulled my hair out searching for the cause of the problem.
    I'm getting really sick and tired of the buggy Opera. It's again like it was on previous presto based builds.
    Granted, dev channel can have issues, but now O18 has been released on the Next channel there is no excuse.

    I've tried hopping on the HTML5 youtube test and off again - No change.
    The resolution is always at 360p and cannot be set higher, even if the video itself offers 720p or 1080p.
    I use Internet Download Manager to download the video, and it correctly lets me choose from all available resolutions.

    Please some comment from any Opera dev? Will this be fixed anytime soon?

    Cheers.

    Edit:
    OK got it going now. For those with the HTML5 mess, do this:

    Right click on the video and choose "about HTML5" or something.
    You will be asked to join the HTML5 Trial. If you are not on the trial, JOIN FIRST.
    After that, LEAVE the trial.
    If you are already on the trial, just choose LEAVE.

    In Opera, choose settings-Privacy and Security-Clear browsing data.
    Close Opera, and open it again.
    Play a video - Opera will now use Flash player.

    I just saw that Chrome users also have these issues, and that's something that Opera is "inheriting" from using the same engine.

    OMG, it really worked!! Thank you so much~~

  • bug still there.. have to use firefox to see videos in more than 320p...

  • I can also confirm that the bug is still present in Opera 18, version: 18.0.1284.63

    The reason for the switch to Chrome's rendering engine was that these kinds of things wouldn't happen anymore, but there still seem to be [bad] differences between the browsers 😞

  • Magic Actions for YouTube extension resolved all problems 🙂

  • yeah, it has "force player type" setting now 😃

  • I had the similar problem but i found the solution. Adblock extension is the culprit for this problem. Disable the adblock and check the resolution.

    1. Disable adblock
    2. Close the browser
    3. Open the browser
    4. Check youtube video resolution
    5. If it works than enable the adblock extension

    This is the exact problem i had.

    http://my.opera.com/community/forums/topic.dml?id=1802212

    Hope it works for you.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.