Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Deleting Spam Doesn't Remove All Spam

  • Hi davehawley. The point is to delete spam from Opera which will delete the spam on the server side. So, accessing mail on the web browser is something I don't want to do. You mentioned that setting Opera to delele mail from the server and local end. Where in Opera's settings can I do that?

  • In the main menu, click 'Mail and chat accounts...', then select the particular account from the list in the window that appears and click 'Edit...'. Go to the 'Incoming' tab and place a tick in the the following two places, 'Leave messages on server' and 'Until I permanently delete them'.

  • ▲▲ What he said! ▲▲
    🙂

  • In the main menu, click 'Mail and chat accounts...', then select the particular account from the list in the window that appears and click 'Edit...'. Go to the 'Incoming' tab and place a tick in the the following two places, 'Leave messages on server' and 'Until I permanently delete them'.

    There are no such options on my Incoming tab on my mail account. Are you sure you're talking about Opera 12.16?

  • POP email accounts might have it. I got only IMAP accounts and there indeed is no such setting.

  • Definitely version 12, there is no mail facility at all in the later Opera versions post 12.
    What does appear in that tab?
    I've no experience of using IMAP, only POP, so if the options don't appear in IMAP accounts and that's what you're using I can't suggest anything I'm afraid.
    🙂

  • I don't think having any client is a good idea for security reasons*:sherlock:*

  • So, accessing mail on the web browser is something I don't want to do.

    Why not? You should check if your actions in mail client are taken effect in your mail.

  • Are you using pop or imap? Are you emptying the trash after deleting the spam?

  • Hi guys. I'm using IMAP. >

    So, accessing mail on the web browser is something I don't want to do.

    Why not?

    You got to be kidding me.

  • I'm using IMAP. And there are no options as linuxmint suggested.

  • You have two nods of vulnerability instead of only one.

  • You have two nods of vulnerability instead of only one.

    What this comment (and yours other ones) has to do with what the OP is asking ?

  • I'm using IMAP. And there are no options as linuxmint suggested.

    Those are for pop accounts.

  • I see.. no problem then. I'll figure it. Thanks for the help anyway guys. I appreciate it except for the troll with the troll comment.

  • I see.. no problem then. I'll figure it.

    In the account settings, check in the imap tab if the folders for sent mail, spam and trash are correctly set.

  • Hi leo. How can I know if those folders are correctly set?

  • Hi leo. How can I know if those folders are correctly set?

    See if each one one has the correct corresponding imap folder.

    Basically check if the trash field has the correct imap trash folder and so on.

  • In the "All Messages/Spam" message list, click on the "settings for this view" button on the toolbar above the message list, expand the "show" options and make sure all the show options are checked so that "All Messages/Spam" shows all spam messages that are marked as spam. On a side note, you can uncheck "show spam" for other views so they don't show spam.

    Also, if your IMAP server learns from messages you add/remove from the IMAP spam folder (that you set on the "IMAP" tab in the account's properties), make sure to check "disable local spam filter for this account" on the IMAP tab in the account's properties.

    If you right-click on "All Messages/Spam" and goto "properties", there are some options. One of them is "learn from labeled messages. This causes Opera to learn from messages you mark/unmark as spam. It takes a while to train though and you have ot unmark false positives for a while. Since this is IMAP, Opera will add a spam flag to each message marked as spam in Opera. But, if the IMAP server doesn't support that flag (it should), there might be a problem with Opera redetecting it as spam or it not being marked as spam properly. Given that, you might have to access a webmail just this one time to fix things. Also, unchecking "learn from labeled messages" and closing out of the properties and then going back in and rechecking "learn from labeled messages" should reset what Opera has learned. But, you shouldn't use "learn from labeled messages" unless you really know you want to.

    Also, when you delete spam messages in "All Messages/Spam", shift + del them if you don't want them moved to trash first. Otherwise, you then have to permanently remove them from the trash.

    Also, under the you@example.com IMAP folder access point, go to the IMAP folder view the problem spam messages are in and shift + del them from there.

    If you have a trash folder set on the "IMAP" tab in the account's properties, only use shift + del in the trash view or IMAP trash folder. For other views, use del to move to the trash folder and then empty the trash or use shift + del. Using shift + del outside of the trash folder with a lot of messages can trigger a bug in Opera. So, that's why you avoid that.

    There might be something messed up with the IMAP account. You can delete it from Opera and add it back in to fix things. Or, you can try unsubscribe from an IMAP folder (Menu -> mail -> imap folders) and resubscribing (besides INBOX) to fix a certain IMAP folder.

  • Hi burnout. I dont see "disable local spam filter for this account" option anywahere on my browser. I also dont see "learn from labeled message" either. Are you sure youre talking about Opera version 12.16?