Opera not loading pages?

  • Hi guys,

    I asked this quite some time ago since I keep facing it since Opera 15 was released but it seams no fix yet.

    Every 1/4 (approximately) of the time I open a new tab and type the address, the page won't load. The tab turns white (the speeddial goes away), the address bar becomes blank and it shows the page loading indicator but nothing happens. After this, the tab becomes unusable so I have to close it and open a new one.

    This happens when I run Opera and I have many tabs opened. Some of them will just be like this and if I want to get them back I need to close Opera (since I cannot copy the address in that tab).

    I also experience this when I click a link inside a page (open in new tab).

    This is incredibly annoying, especially sine I want to switch to the new Opera for good (12.xx has huge memory issues). I kept waiting to see if this will be fixed, I tried normal and portable installation but no luck. And this is happening on both my Windows PCs.

    Someone suggested that his ( https://forums.opera.com/topic/3089/speed-dial-not-loading ) might help but it doesn't. I tried a portable installation with 0 plugins and extensions but no luck. I also tried disabling the firewall and AV software as well as any custom scheduled task or tune up suite/function.

    Now I also experience this on my work computer.

    Any info on this?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.