Any way to get sound notifications to work for incoming mail?

  • I know sound notifications work on windows machines, but nothing I do seems to work on linux. Currently fiddling with a fedora 20 machine. I have "play sound when new messages arrive" checked and a working wav file selected ( have tried others, makes no difference ). Any suggestions? I've done quite a bit of googling and have come up empty. Thanks!

  • Not sure what to do. I think Opera on Windows uses the Windows PlaySound() function to play the wav file. I don't know what Opera uses on linux for it, but if you can find out (or find out the PlaySound() equivalent on Linux), you could at least use that command/function to try and play the wav file on the command-line or in some simple little C++ program to make sure it works like that. If it doesn't, that might be the reason it doesn't work in Opera. Then, your goal would be able to get it working outside of Opera.

    You might check ~/.opera while Opera is closed and edit operaprefs.ini. Under [User Prefs], remove the "Show notification for new messages" line so that Opera uses the default of "checked" for that. Then, in "mail/accounts.ini", make sure the wav file is set and that the play sound option is truly enabled for that account.

    That's about all I can think of.

  • Opera for Linux doesn't support *.wav files. Haven't tried other formats, but they consider *.wav a proprietary MS format and won't play it even if your system does.

  • Thanks for the heads up. I checked in the latest x86 lubuntu with Opera 12.16 and indeed can't get anything to work. I tried a wav file, a vobis file (with oga, ogv and ogg extensions) and an mp3 (also with a .wav extension).

    Never paid attention to this on Linux before. Odd that the UI for playing a sound and choosing the wav file is there even if it doesn't work.

    So, I guess there's nothing you can do.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.