Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 16.0 / Mac OSX 10.8 - Cannot access https: site requiring personal Keychain login cert.

  • I've discovered a bug where Opera will not access my company's Intranet sites that require a PKI certificate that is in the Mac login keychain. It just gets stuck on the little "loading" spinner icon and nothing ever comes up. The sites can be accessed fine using other browsers (Chrome, Safari, Firefox). I've checked Opera settings and everything looks good. Is this a known issue with the new Chromium-based Opera?

    Also, it doesn't appear to work with Java on Mac (but neither does Chrome). Is it supposed to?

    By the way, performance on Opera 16.0 is very much improved from the Presto-based versions. I ran some tests and Opera beat Chrome, Safari, and Firefox in Octane v1 and Peacekeeper tests, and was very competitive in Sunspider and RoboHornet. Very exciting! Now if we could just hammer out the compatibility/functionality issues....

  • I have experienced the same issue on the same version of Opera and OS X.

  • It could well be that this scenario is not covered by the existing feature set. I’ll investigate.

  • Opera 19 on Mac access Keychain right now.

  • Correct - The feature has been re-added with recent updates. Problem solved. Now if we could just get our bookmarks back....

  • This feature still does not work for me. I tried it using Opera 19.0.1310.0 on OS X 10.9.0.

    It does work in Safari 7.

  • Actually, you're absolutely right....

    If you go into Opera>Preferences>Privacy & Security>Manage Certificates it will open the Keychain App. However, Opera still will not find/use the certificates. I can't get into my corporate intranet with Opera but can with every other browser. (Same SW versions for OSX and Opera as yours)

  • Originally posted by daniel:

    It could well be that this scenario is not covered by the existing feature set. I’ll investigate.

    Do you have any updates? If this feature has been removed permanently, that would be disappointing.