Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

In order to introduce new security features and enhance your experience with Opera Forums we had to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button.
Apologies for any inconvenience caused.

Bizarre Trackpad Behaviour

  • Hiya

    For years now (3 different laptops, 3 different versions of Ubuntu), I've had this really weird problem with Opera:

    If I make a delicate (1cm)(left to right) swipe on the trackpad scrollbar, it spontaneously abandons the current page, and searches (google) for whatever is in the clipboard.

    Drives me insane - it happens about 50 times a day. Disabling mouse gestures doesn't make a difference... I've just spent a couple of hours trying to catch it as a jquery event... not having a lot of luck there either.

    Any ideas on how to stop this?

    (
    Opera Details:
    Version 12.16
    Build 1860
    Platform Linux
    System x86_64, 3.13.0-35-generic
    Ubuntu 14.04
    )

  • Sorry - that should have been "right to left"

  • Trackpad scrolling is being interpreted as a middle-click? Strange ...

    Under Preferences > Advanced > Shortcuts there is a button called Middle-click options. In Linux, there is an option to treat middle-click as Paste or to enable fast scrolling - it would seem you're set to Paste currently. If the middle-click does not occur over a text area, Opera treats it as "Paste and go" and of course if the pasted text is not a URL this results in a search for that text with the default search engine.

    You can either try to figure out why scrolling is being translated as a middle-click, change how Opera responds to middle-clicks (in Preferences as stated earlier), or go into opera:config and tell it not to do that "Paste and go".

  • Ah you're a genius. Fixed. Thank you, thank you, thank you.

Log in to reply