:tools: Scheduled maintenance

Heads up! Downtime for the Forums, related to the NodeBB upgrade, is planned for Thursday, December 14, starting from 10:00 UTC.
Please make sure to finish all your posts before this time. The downtime should only last for a few minutes.

Invalid Server Certificate

  • I use Opera on a Windows "XP" computer. I get an Invalid Server Certificate each time I try to connect to many sites, including github. I know Microsoft has stopped supporting "XP", but I found out it's a browser thing. I mean I get the same message when using Opera, Chrome or Firefox, but when I use other browsers like Qupzilla, I can connect with no issues. Is it because Opera hasn't updated "XP" support as well? Any way around this?

  • I use Opera on a Windows "XP" computer. I get an Invalid Server Certificate each time I try to connect to many sites, including github. I know Microsoft has stopped supporting "XP", but I found out it's a browser thing. I mean I get the same message when using Opera, Chrome or Firefox, but when I use other browsers like Qupzilla, I can connect with no issues. Is it because Opera hasn't updated "XP" support as well? Any way around this?

    Are you on XP SP3 and are you sure chrome works? Firefox uses different SSL libraries so usually Chrome/Oera fail but Firefox works.

  • Opera 24 uses the Windows Certificate Store.

    Try to get:

    • DigiCert SHA2 Extended Validation Server CA
    • DigiCert High Assurance EV Root CA

    from https://www.digicert.com/digicert-root-certificates.htm and add them to Windows Certifacte Store in Trusted Root Authorities

  • The root of most security certificate issues (at least that's been my experience) is the Date on your computer set wrong. And as skipryper suggested, if your still using XP make sure it has at least SP3.

  • The root of most security certificate issues (at least that's been my experience) is the Date on your computer set wrong. And as skipryper suggested, if your still using XP make sure it has at least SP3.

    It's XP2. Never upgraded. Maybe this is the issue. Thanks so much!

  • I use Opera on a Windows "XP" computer. I get an Invalid Server Certificate each time I try to connect to many sites, including github. I know Microsoft has stopped supporting "XP", but I found out it's a browser thing. I mean I get the same message when using Opera, Chrome or Firefox, but when I use other browsers like Qupzilla, I can connect with no issues. Is it because Opera hasn't updated "XP" support as well? Any way around this?

    Are you on XP SP3 and are you sure chrome works? Firefox uses different SSL libraries so usually Chrome/Oera fail but Firefox works.

    Thanks for writing back. I am on XP2 and no browser works other than Qupzilla etc.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.