Shared Opera profile doesn't share the open tabs

  • I'm dual booting Ubuntu and Windows, both on 64bit. Although I changed all the relevant paths in opera:config in Ubuntu to point to the locations on the Windows installation, somehow the current session is loaded from the linux location. Automatic Window Storage File points to the Windows installation yet the autosave.win file seems to be loaded from the linux local directory. As a result, I have different tabs open in each OS. I should probably mention that the Windows partition is automatically mounted at startup and that all the other paths (for bookmarks, speed dial etc) seem to work just fine.
    Is there any way to solve this issue? Is there any way to properly share an Opera profile with a completely local solution?

  • An old bug. You can't change the location of your session files, even if the Preferences Editor suggests otherwise

  • Thanks for taking the time to answer, mochikun. What you are saying seems a bit weird to me, though. Because I was able to do just that in the past, even recently. Granted, it was always a bit of a messy business with Opera not having a centralized profile which you can switch, but it was still possible to change that path. I had this setup just a month ago before upgrading the OS.

    Just to make sure we're referring to the same action: I do not intend to change the autosaved session to a file with a different name. All I ask Opera is to keep saving to "autosave.win", but one placed in a different location.

  • Originally posted by krusade99:

    What you are saying seems a bit weird to me, though. Because I was able to do just that in the past, even recently.

    You did just what?
    It's not clear to me what you try to do. From your description I figure that you keep 2 different profile folders for Win and Linux, but that you point all folders that opera:config allows you to configure to common locations, e.g. bookmarks, wand etc.

    I do not intend to change the autosaved session to a file with a different name. All I ask Opera is to keep saving to "autosave.win", but one placed in a different location.

    Understood. But you can't change neither the name nor the location. The location can't be outside of the the profile folder.
    The only solution would be to let the different operating systems share a single common profile (using the -pd command line switch), but this is bound to create conflicts with the different naming schemes of the file systems.

  • Or of course to link the Linux location to the Windows location ...

  • What I'm doing is pointing Opera in Linux to the file paths of the Opera in Windows with the help of opera:config. I couldn't do it otherwise, as the linux filesystem is not seen by the Windows OS. And I didn't want to experiment with an external shared profile (-pd command) out of fear of complications and future updates that might remove this feature and break my setup. What I planned was to have 2 separate installations and the absolute minimum number of specific shared assets (bookmarks, mail, wand etc). I avoid sharing unnecessary resources (like fonts and toolbar styles) because they may depend on system resources that can be incompatible between the two operating systems.

  • And it appears that I managed to do this again - successfully point Opera in Ubuntu to the "autosave.win" file in Windows. Sadly, I cannot trace back to the defining setting as I changed quite a few paths in opera:config and was not aware when this change took place. I only noticed the issue was solved when I logged back into Windows. I did a few tests and it seems to work consistently. So apparently you can point Opera to a different "autosave.win" file.

  • Originally posted by krusade99:

    So apparently you can point Opera to a different "autosave.win" file.

    I can't. Just tried with latest version and fresh profile. Even the bogus "autopera.win" in the default setting instead the correct "autosave.win" is still listed in opera:config, which alone is a strong indication that Opera ignores the settings.

    I also tried to symlink my Linux session file to autosave.win of the Windows installation. Doesn't work either. In Linux Opera overwrites the symlink with its "real" autosave.win.

  • I suspect there is another config file that needs to be shared for this setting to work. If you think it helps to elucidate this I can go through opera:config and write down all settings I've overridden (mainly paths).

  • Thanks, but we should talk about your problems, not mine. What puzzles me: What exactly is your problem? If the setting mysteriously works for you (maybe the power of 64bit?), then everything should be OK. If your Linux Opera really uses the session files of your Windows Opera (and not merely points to them), then both systems must start with the same open tabs.

    What happens when you temporarily move the files in your current Linux /profile/sessions folder to another location and then start Linux Opera? If Opera creates no new autosave.win I will be impressed 🙂

  • Opera in Linux really uses the files of the Windows installation, I have the same set of tabs open in both now. So it writes to that file as well and I can see the sessions in that folder in the session list accessible from the Opera menu. When I first noticed this I did a few quick tests to confirm it works both ways and it did.

    My problem was that, although I had this Windows path set for "Automatic Window Storage File" in opera:config, the browser continued to load the local file. I knew this worked in the past so I changed other paths to point to the Windows installation in the hopes there is some other condition that needs to be met for this setting to apply. As you might imagine, this went as totally unscientific trial and error. Because of this I could not decide which change is the one responsible for the success. I was making changes expecting that on success Opera would load the tabs I had open in Windows. This never happened because when that path was applied Opera first wrote to that file the tabs I had open in Linux, overwriting the windows tabs. So I only noticed the change when I logged back into Windows.

    Opera might create a new autosave.win if I move the file, but it still uses the one in the Windows folder, I have proof of that. I am in Windows now so I cannot test this at this moment, but I believe the outcome of this test could not really prove much in these circumstances.

  • Originally posted by mochikun:

    What puzzles me: What exactly is your problem? If the setting mysteriously works for you (maybe the power of 64bit?), then everything should be OK. If your Linux Opera really uses the session files of your Windows Opera (and not merely points to them), then both systems must start with the same open tabs.

    Not sure if I properly answered that one. The problem is gone but not in a way that can actually help other people who encounter this issue. You seem to have this problem yourself and my resolution certainly doesn't help you. It will not even help me if I decide to re-install and create this setup again. What I wanted with this thread is to figure out exactly what needs to be done to achieve this in a consistent repeatable manner. See why it doesn't work to just change that path.

  • Originally posted by krusade99:

    Opera might create a new autosave.win if I move the file, but it still uses the one in the Windows folder

    Now this would be completely incomprehensible and - if true - would mean that Opera saves sessions automatically into 2 different locations. If by "uses the one in the Windows folder" you mean that upon startup your Linux Opera opens the last tabs you had open in Windows, well this is is relatively easy. Probably this is what you did:

    1) Preferences > General > Startup > "Continue saved session"
    2) opera:config > User Prefs > Windows Storage File > ""path/to/Opera Windows/sessions/autosave.win"

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.