12.15 forces Google as search engine

  • One change sneaked under the cover in 12.15. If you use an alternative search engine (I use Startpage) you will find that every time you restart Opera it will have set the default back to Google. Although you can edit the search engines and set the box to use your preferred search engine as the default you will find the box cleared next time.

    Back to 12.14 here...

  • Yeah, I'm getting the same problem too. People who were testing the RC noted the problem, but it looks like it wasn't fixed.

    But, it also seems like not everybody is having the problem.

  • I don't seem to have this problem — I changed it to Wikpedia, and restarted without the default being changed .

  • It seems to be happening only if you choose a custom search as the default one.

  • Originally posted by LeoCG:

    It seems to be happening only if you choose a custom search as the default one.

    Confirmed.

    Opera 12.15
    Fixes and Stability Enhancements since Opera 12.14
    Fixed an issue where the search bar's default engine could be overridden by third-party apps.

    As it is for now, this fix does more harm than benefit.
    I hope that Opera devs will look into it.

  • I have this problem too on Archlinux on a custom search engine "Startpage Web Recherche".
    Is it possible to report this bug to an official bug tracker ?

  • These days I don't use Google Search since it is incompatible with MVPS Hosts - each search result you click on with Google gets changed to one via Google's servers as part of their tracking and since these get blocked by MVPS Hosts it makes them unclickable. In any case I want search results not all the other garbage Google puts on its search pages these days. Startpage gives me just that, with the same results as Google plus some more.

    Hopefully they will address this issue (which has been also discussed on the developer forums) before they move to Webkit/Blink with another bunch of issues.

  • Originally posted by LeoCG:

    It seems to be happening only if you choose a custom search as the default one.

    I get reset to Google regardless of which search engine I choose. I've tried setting Amazon, EBay, and Wikipedia as the default and it gets reset to Google.

    However, I tried clean USB installations of both x86 and x64 versions of Opera and was able to set Amazon, EBay, and Wikipedia as default without it resetting to Google.

    So, I'm not sure what's going on with the Opera I normally use.

  • Originally posted by ugly95:

    Originally posted by LeoCG:

    It seems to be happening only if you choose a custom search as the default one.

    I get reset to Google regardless of which search engine I choose. I've tried setting Amazon, EBay, and Wikipedia as the default and it gets reset to Google.

    However, I tried clean USB installations of both x86 and x64 versions of Opera and was able to set Amazon, EBay, and Wikipedia as default without it resetting to Google.

    So, I'm not sure what's going on with the Opera I normally use.

    If the search engine is not on the list that ships with Opera, it can't be set to default and survive an Opera 12.15 restart. All those examples you noted are on Opera's as-shipped list of search engines. Something like StartPage is not, so it gets reset if you have added it to the list and try to make it default. Whatever Opera did to 12.15 to block a third-party app from hijacking Opera's default search engine also prevents a user from setting a default search engine that's not on Opera's as-shipped list.

  • Originally posted by blackbird71:

    If the search engine is not on the list that ships with Opera, it can't be set to default and survive an Opera 12.15 restart. All those examples you noted are on Opera's as-shipped list of search engines. Something like StartPage is not, so it gets reset if you have added it to the list and try to make it default. Whatever Opera did to 12.15 to block a third-party app from hijacking Opera's default search engine also prevents a user from setting a default search engine that's not on Opera's as-shipped list.

    I understand the issue. And for the two clean, USB installs I tried it works exactly like that.

    But for some reason, my regular install won't even let the other as-shipped search engines become the default. It resets to Google no matter what.

  • After updating from 12.14 to 12.15 my search engines are unaltered.

    I don't know why some people are having this problem. I was even able to install 12.15 on a different folder, set a new custom search engine as default and when restarted it's still there.

  • Extremely irritating.

    I don't know why Opera is in love with Google. The worst search engine by my standards.

    I really regret upgrading now. Now its just as annoying as the mobile app where you have to keep switching.

  • Originally posted by rafaelluik:

    After updating from 12.14 to 12.15 my search engines are unaltered.

    I don't know why some people are having this problem. I was even able to install 12.15 on a different folder, set a new custom search engine as default and when restarted it's still there.

    Well, you could try rereading davews', LeoCG's, mine and blackbird71's posts. It might help you understanding.
    If after 100 attempts you still won't understand than I'm afraid, there is no hope for you ;)

  • Test. Clean install. I have set a NEW CUSTOM search engine as DEFAULT. After restarting it's still there as default.

  • Which NEW CUSTOM search engine did you set as DEFAULT?

  • duckduckgo.com for example...
    It isn't among the default search engines of my locale.

    But oh, DuckDuckGo is part of English locale defaults so, maybe you're right... Can you tell me the one you're testing?

  • O.M.G.

    Yeah it's happening, it's being reset. But please (to the topic opener) don't spread false claims around saying Opera is forcing Google.
    Opera screwed up this time. It shouldn't have given the opportunity of this to happen, now *tards will be all over the web spreading FUD that Opera is part of the new Google "Skynet" plan "Blink".

    Originally posted by RaphAstronome:

    Is it possible to report this bug to an official bug tracker ?

    Yes please let's report it here:
    https://bugs.opera.com/wizarddesktop/

  • AFAIK, users already complained at the time 12.15 was a RC. So, Opera devs should know already about this.
    Nevertheless, let's hope they will fix the fix.

  • Holy hell, I can't believe it. I don't want to use Google and Google products. For this reason, I'm using Opera. But it's really disturbing. Moreover, it's a final release. That's incredible. I hope you'll fix it.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.