Fedora 20 new i386 install - cannot access web

  • Installed 12.16 on fedora 20 in virtualbox and no web pages will open (actually only google.com works; nothing else). Deleted the ~/.opera folder with the same results. When I first installed firefox I had to disable all ipv6 to get it working but don't see how to do the same for opera even in opera:config. ipv6 is disabled on my net interface. Get the same symptoms under another user account. Net access is fine & browsing w/ff is fine & dns resolves ok. Never used opera b4 & wanted to try a ff replacement. Actual error text: "Network problem. You tried to access the address http://redir.opera.com/www.opera.com/firstrun/, which is currently unavailable.

    The only web site which will open is google.com and searches actually work there. Nothing else opens even from any link there; only the url changes with the same error as above. nslookup for the firstrun address returns 198.105.254.23 with a mirror at 244.23. Any ideas?

  • What's virtualbox for, here? You running the Windows version?

  • I'm running the linux version: opera-12.16-1860.i386.rpm is what I installed. Virtualbox is because my host is W7-64 and I want to move away from it permanently but am somewhat new to linux (my nix* experience is old solaris & old rhel but it never was my primary usage & I've been away from it for years) and wanted to figure out how to do everything in Fedora 20 that I do now in W7 before I untether from MS.

  • Okay then ... Opera 12 for Linux does support IPv6, but that can be a problem itself. Linux has IPv6 support enabled by default; if your ISP or network does not support it then Opera can end up waiting forever trying an IPv6 host name lookup. There is no switch in Opera to turn off IPv6 support, you need to actually turn it off in Linux.

  • Thanks for the info. That's the problem I'm running into then. My isp doesn't support ipv6 so even though I've disabled it in Fedora since there's no option to disable it in opera I don't think it'll ever work. For troubleshooting I installed opera in my W7 virtualbox vm and it worked fine. So it seems to be related to how Fedora 20 handles the ipv6 even though it's disabled since I didn't have to disable anything in a w7 vb vm in regards to ipv6 to get both ff & opera working fine. Of course I'm assuming that neither ff or opera change how they handle ipv6 between platforms & recent versions.

    Regards.

  • If you disabled it in Fedora (and not just Firefox), then Opera should work fine. It's only when Linux thinks IPv6 should work but it isn't actually available that you have problems.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.