Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

opera v74.0 will not install in Chalet_os

  • I downloaded the deb file...opened it with the software installer....and clicked on the install button.

    it flashed and returned to the page showing the install button . It did not install !

    so i opened the terminal, and tried to install it with gdebi command.

    It came back with " this package is uninstallable Depedency is not satisfiable: libgtk-3-0 (>= 3.21.5)

    synaptic does not show any libgtk greater than 3.0 so what do i do here?

  • @seadevil If I understood correctly, you need at least version 3.21.5 to install Opera.

  • @leocg I guess that is what the problem is according to what that depency statement is.

    anyway, i just went to opera.com and downloaded an older version. so at least i can use it.

    could not find anywhere i could get a higher of libgtk version than 3.0. not on synaptic or online.

  • Chalet_OS is an Xubuntu-based Linux?

    Try looking at https://packages.ubuntu.com/search?keywords=libgtk-3-0 and following the link to the version you want. Then on the version page, scroll down and click on the architecture you want to find the download or how to download the package you want.

  • @burnout426 ok, thank you for the directions.

    I downloaded the file...opened the terminal....and tried to install it via gdebi as synaptic did not have it.

    this is what i got :

    Building dependency tree
    Reading state information... Done
    Reading state information... Done
    This package is uninstallable
    Breaks existing package 'libgail-3-0' dependency libgtk-3-0 (= 3.18.9-1ubuntu3.3

    have no idea what to do next.

  • @seadevil ok, i went thru the hassle of re-installing Chaletos again and repeated trying to install opera and got the same exact error again. Downloaded the libgtk that was required and got the same error again...not installable !

    any help would be appreciated

  • @seadevil Hmm, looking more at the ChaletOS page, it looks like it's really old. There's probably a lot of things that have to be updated in the OS. I don't even see a support forum for it anymore. You can try asking https://sites.google.com/site/chaletoslinux/Author what can be done if anything.