Image Won't Load in Opera

  • This is the strangest thing. The link below won't open in Opera (nor Kongueror) but it does in Firefox. It is a plat map of an area in Cedar Rapids. When I check its properties, it says it is a gif file. I have tested Opera with other gif files, and it works. Note that in Firefox, it does not have the "http://" at the beginning, but if I copy/paste it to Opera or Konqueror, it puts it on. Likewise if I copy it to Firefox with the "http://" on it, it strips it off. That's probably not significant to the problem.

    I've had other situations where Opera doesn't show images but Firefox does, and it's very frustrating. One I have at this time is in downloaded email, but I know of no way to link it here. In my email provider program, the properties says it is jpeg. There should be no problem with that, but the image didn't download.

    http://crgis.cedar-rapids.org/Freeance/Client/PublicAccess1/index.html?appconfig=City_Assessor_GIS&cmd=zoomTo&themeid=25&fieldname=NEIGHBORHO&fieldvalue=107

    I'm using Opera 12.16 in MEPIS 11 on an ASUS M4A785TF-V EVO motherboard.

    Can you load this? If so (or not), do you have any thoughts on why I can't? Thank you.

  • I tried opening your link in ie11, opera23, & ff26 (Windows 7) and all of them return:

    "Fatal Error: Unable to load config file."

    I wasn't able to get my fedora opera 12.16 to work to try it (see my other post for details if interested) however fedora ff31 gives the same error as above. Do you think it's possible Firefox may be opening a cached version of the file? I agree the protocol ref is likely irrelevant. I'd remind you there are loads of advanced settings in opera related to images directly & indirectly which may be related to your "other situations".

    While I don't have any ideas for an outright solution I just wanted to help you out with a little more info since no one else had replied & wanted to give something back to the forum.

    Have you tried other maps of other areas with the same tool? Have you asked the assessor's office if they can access the same link/tool/map? I don't know why a gif would need any kind of config file and haven't seen that b4 when accessing any kind of image so I'd guess the Freeance tool is trying to load it dynamically from the web page...unsuccessfully. That would steer me back to contacting the assessor's office to see their success or method or symptoms.

  • Thanks for your tests and comments, especially for your test using ie11. I'm surprised that didn't work, because I just naturally assumed that they were probably writing it for Windows.

    I tried to call two different people at the assessor's office yesterday afternoon (Friday), but there was no answer, so I assumed that they had started the holiday early. I will call Tuesday (after the holiday), or as long as it takes to get someone to ask the question.

    I have spent over a day and a half on one of the "Other" problems where an image in an email forwarded by a dentist from another person in an organization didn't appear, and I had both tmails, so I could compare them. I found reference on the internet to a possible problem can occur. It is shown on the window that opens when the image is right-clicked, and "View Image info" is selected. For the image that is reliable, there is a line "Associated Text: Image". The images that aren't reliable to not have that line at all.

    Thanks again. I will report back when I have more info.

  • This problem turns out to be more complicated than I thought. It seems to have to build a foundation of steps before it will put the image up. I tried the URL in Windows XP that I posted above, and it wouldn't work in either IE or FireFox. So I will go through the steps in case you want to take the time to try it.

    First, tho, I will say that I called the assessor's office to find out what OS their system was made for, and the lady I talked to said they're in the same boat I am - the IT's make the system and they just hope they can get what they need from it. I didn't really believe that they didn't have more info than I do, but I said "OK" and hung up.

    Then I started digging deeper. I discovered that these steps will get to the image in question that won't work in my Opera.

    1. Go to: http://www.cedar-rapids.org

    2. Go to the bottom of the page, in the blue area, and click on: "City Departments"

    3. In the left column, click on: "City Assessor's Office".

    4. Under "City Assessor's Office", 2nd Paragraph (One liner) is:
      "Please visit the Assessor's Website". Click on "Assessor's Website"

      NOTE: If you want to skip steps 5 through 8, you can enter the example I gave in step 8.

    5. Under the main view are 2 entry points. Keep track of this because you will need it again (one way would be clone the tab). Click under "City Parcel Viewer"

    6. Read text in black square as you wish, click on "OK"

    7. You now see an overview of Cedar Rapids. Click on the "+" at upper right until it will allow you to click on a plat (any plat) and get its details. I think you will need 3 clicks.

    8. That plat will be highlighted, with a grey square giving its details, including address at the top of the square. Note that or copy it. For ex. I just chose 1506 YUMA DR NW

    9. Now go back to the "Assessor's Website" that I said to keep. Under "Property Search", enter the address number (1506 in my example) in the first space, and "YUMA" in the second, and click "Search by Address".

    10. You should get a page titled "Results of Parcel Search:". There will be an entry under the heading "GPN".

    11. Right-click this entry and choose "Open Link in New Tab".

    12. You will now see a view of the property. Under it is a layout of the lot, and under that are FOUR options. Click on the 2nd one "View complete GIS map".

    13. you are now looking at the loading of the image that my Opera won't open. It is titled "CITY ASSESSOR PARCEL VIEWER".

    If you go through all those steps, I would sure like to know your results.

    Thanks

  • Oh, No! Opera goofed up my post! And I don't see any way to edit it! Nor could I see any way to preview it. What's going on with Opera?!

    I wrote my above post with numbers 1 through 13. It broke them down into 2 sets - 1 through 4 and 1 through 9. To make sense out of it, you will have to add 4 to each of the numbers in the 2nd set of numbers. This is as frustrating as Open Office and LibreOffice gets with their numbering system that tries to tell you what you want to do! Nuts.

    Opera goofed me up the first time also. I looked for a way to preview it, and ended up losing everything I'd written-had to start over. And it said it was my FIRST post!! Is this really Opera?? I used the same password! Crazy!

  • First post fixed ... the underline characters don't work well in Markdown. You only have 30 minutes in which to edit a post, so make sure you proofread it. The gear icon (below the badge) has options to Edit or Delete a post, though last I checked you needed to reload the page before the menu actually shows up. (And yes, the gear icon is very light except when you hover it, so is the quote icon next to it.)

    I don't really understand how markdown handles lists, but I'll see if I can fix that as well (though with the first post fixed that may be redundant ...)

  • Well ... lost the numbers on 4 and 5 now. :(

    Suffice it to say, the link in the first post does work (in Opera 24 on Windows) - without all the steps.

  • Tested ... no map in 12.17 for Windows. Changing user agent (Right click > Edit Site Preferences > Network) to "Mask as Firefox" fixes it.

  • I went thru your process on all browsers I used on my first reply (w7 & fedora) and they all opened the gis map fine with default settings. I didn't have to alter any w7-opera settings. The only glitch I encountered was w7-ff where the 1st time it did not open until after I previewed it first (1st link). Subsequently the 2nd link worked fine also. Then I retried the OP url and got identical symptoms as explained above (it still didn't work in any browser/any platform/same config file error).

    Then I took the new url from the ref address (1506 yuma) and pasted it into a text file, closed each browser, reopened each browser (new session) and they all opened that url just fine. Here it is:

    http://crgis.cedar-rapids.org/Freeance/Client/PublicAccess1/index.html?appconfig=City_Assessor_GIS&cmd=zoomTo&themeid=0&fieldname=Landbase.DBO.TaxParcel.TAXPIN&fieldvalue=142032901100000

    hth. good luck.

    p.s. the preview looks like the url will be truncated...the last # is:
    142032901100000

  • As posted earlier, the forum uses Markdown, and as a result links containing underlines get messed up. The link in the first post has been fixed (though the actual text is still wrong, the link is correct). The link in the first post works fine in Opera 24 for Windows. But in Opera 12.17 for Windows, it does not unless you Mask as Firefox. Note that any of the user agent settings do not change how Opera actually works ... they tell the website you are using a different browser so that they will send code appropriate to that browser. Some sites don't know what Opera is and thus don't know what to send it - masking as a different browser that they do recognize can fix many sites.

  • sgunhouse said:

    Tested ... no map in 12.17 for Windows. Changing user agent (Right click > Edit Site Preferences > Network) to "Mask as Firefox" fixes it.

    That's amazing! When I selected "Mask as Firefox" for "user agent", it worked in Opera!!
    Setting up the "user agent" was strange, though. I Right-Clicked over the image that wouldn't load, and did not get "Edit Site Preferences". So I did an Internet Search, and found I could do it through "Tools>Quick Preferences>Edit Site Preferences". Then later, I Right-Clicked the "gear" while looking for the edit option, and there was "Edit Site Preferences"! I tried it as just FireFox first, and it didn't work. Then I selected Mask as Firefox, and it worked!

    I'm wondering how the above quote will work. I don't see its author listed so I don't know if it will be included. (It wasn't, so I added it.) So I will say thank you sgunhouse for fixing my post, and making suggestions, and doing testing. I don't understand "Markdown" at all, except I did some reading about it on the Internet.

    Also thank you fedora-drew for your testing. When I copied the URL you provided, it gave me the error message "Fatal Error: Unable to load config file." I did have to paste the number on to the end of the address. It seems like there's some complex things that take place in these survey maps.

    And, Thanks for verifying that Opera wasn't broken, but just not being recognized by the IT's.

    Now I've still got to see if I can get the edit mode to work!

  • Well, I did not find any way to get into the edit mode. I right-clicked the gear, but didn't see anything that implied editing the text!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.