Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can no longer play unity based games in Opera GX on Mac

  • I have been playing unity based games in my Opera GX on MacOS for a while without any issues.

    A few days ago most unity-based games stopped working, and every one of them shows the following in the console:

    Uncaught TypeError: Cannot read property '1' of null
        at UnityLoader.js:3
        at UnityLoader.js:4
    

    I've tried everything, even deleting the com.opera cache and profile folders and Opera itself and reinstalling from scratch...

    MacBook Pro 16"
    MacOS 11.2 (Big Sur)
    Opera GX LVL2 (core: 73.0.3856.396)

    The same games work fine in Safari and Firefox, but not in Opera GX (nor Chrome)...

  • @cescoaiel Most browsers stopped supporting unity and other plugins a long time ago.
    Last supported plugin was Flash, until last December.

  • @leocg sorry but where did I mention plugins?

    The game worked fine until I updated to Big Sur, and still works fine on Safari and Firefox.

    In the mean time I have found (thanks to useful answers @ the Chrome side) that there is a bug in the Unity engine where their test doesn't allow for MacOS versions >10.x (Big Sur is 11.2)
    Installing a UserAgent plugin so it doesn't send the actual MacOS version, but instead mimics MacOS 10.x fixes the problem.
    Apparently Safari and Firefox have frozen their UserAgent string for this and similar reasons, whereas Opera (and Chrome) have not...

  • @cescoaiel You didn't mention but several pages say that Unity is/was a plugin.

  • @leocg There was a Unity plugin which was EOLed a long time ago, and there is the downloadable Unity WebGL engine which al lot of browser games use, which is started using the 'UnityLoader' javascript.

    In that javascript they look for what OS it is running on, and for some reason a programmer apparently assumed MacOS would never move beyond version 10, as the regex looks for "MacOS 10." instead of MacOS 1[/d].", and even that would cause problems when they reach MacOS 20... 😛