Auto-update doesn't work behind authenticated HTTP proxy

  • I'm using Opera 23 at work and we use an HTTP proxy server. When setting Opera to use the default Windows system settings for the proxy I can access the internet and do all my routine operations. However, whenever Opera tries to update itself I get a prompt telling me have to authenticate to the proxy $1 and a valid hostname within out corporate network. When I authenticate with the correct credentials the prompt keeps coming back and Opera times out after a while.

    I don't understand why the auto-update feature isn't working correctly while the rest of the internet access works like a charm.
    I hope there's a (future) fix for this because I want to stay up-to-date and secure :)

  • Still present using v26 dev... any ideas ?

  • You know, Opera browser is just Chrome, Google developers implement proxy support correctly. Opera Autoupdater is made by Opera developers, this is the reason why it does not work...

  • I added a bug report for that: DNA-30327

  • OK... Nothing until about some correction for such bug (DNA-30327)? It's quite annoying! Whenever I try to use Opera at work, where proxy authentication is mandatory, I never succeed with Auto-Update, besides general navigation seems to run smoothly.
    Note: I use Firefox too in the same 'environment', and its auto-update feature works normally!

  • +1

    it is very old and important issue , I can not understand why Opera devs can not resolve this.

  • I'm a new Opera user and trying it out but this insane, repeated prompting makes me want to uninstall Opera.

  • This is a user forum. Users helping other users. The devs don't really come here much. You might try the Suggestion Box forum or responding to a post on the official blog.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.