Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Problem with date inserted answering mails

  • Re: Opera Mail - message date formatting problem

    I use Opera Mail 1.0 on Windows 10 in German. I am an Opera user from the first days on. Sadly I had to replace Opera, so I got to Vivaldi as browser, and that's not bad. But because Opera Mail is of no real alternative for me even after years I want to fix some problems now to use it the next years.

    Yesterday I got fixed the first problem after years: that spell checking in German is working now. Thanks to this forum!

    Now I want to fix also the issue, taht is mentioned here
    https://forums.opera.com/topic/4651/opera-mail-message-date-formatting-problem/
    and there:
    https://forums.opera.com/topic/42984/opera-mail-the-day-of-the-recieved-messages-is-allways-missing

    I thought I would be able to fix it having read this suggestions, but I was not able to find a German locale file, which I could fix, if there is a similar problem as mentioned for the Polish file. I simply didn't find such a locale file, so I was not able to check if I could adjust something there.

    I found the accounts.ini, and there the formatting lines for responses in each mail account. But there I get only the line

    Forward=\n\n------- Weitergeleitete Nachricht -------\nVon: %:From:\nAn: %:To:\nKopie: %:Cc:\nBetreff: %:Subject:\nDatum: %:Date:\n

    where no adjustment possibility of the date formatting is obvious for me.

    I tried with my system settings on short and long date, too, but in my replies still the day of the date of the original mail is missing.

    Who can please help me a little to get this working for the next years?

    Thank you so much!

    Karl, Germany

  • In English in accounts.ini, you have:

    Reply=On %:Date:, %f wrote:
    

    and:

    Forward=\n\n------- Forwarded message -------\nFrom: %:From:\nTo: %:To:\nCc: %:Cc:\nSubject: %:Subject:\nDate: %:Date:\n
    

    As you can see the %:Date: key gets replaced with the full date.

    If %:Date: doesn't give you what you want, you can use these replacement keys instead to try and build the date yourself to see if you can get something better:

    Customize the message reply/follow-up text
    You can change the reply/follow-up text attribution line shown at the top of email replies and newsgroup follow-ups. An example of this is "On Wednesday, October 27, 2004, Joe Bloggs <joeb@example.org> wrote:" Use the accounts.ini setting and for email accounts, use the "Reply=" setting, while for news accounts, use "Followup=". The following is a list and description of the available parameters:
    
    Email related:
    %n – Name
    %e – Email address
    %f – Name & email address
    Time related:
    %a – Abbreviated weekday name
    %A – Full weekday name
    %b – Abbreviated month name
    %B – Full month name
    %c – Date and time representation appropriate for locale
    %d – Day of month as decimal number (01 - 31)
    %H – Hour in 24-hour format (00 - 23)
    %I – Hour in 12-hour format (01 - 12)
    %j – Day of year as decimal number (001 - 366)
    %m – Month as decimal number (01 - 12)
    %M – Minute as decimal number (00 - 59)
    %p – Current local A.M./P.M. indicator for 12-hour clock
    %S – Second as decimal number (00 - 59)
    %U – Week of year as decimal number, with Sunday as first day of week (00 - 53)
    %w – Weekday as decimal number, with Sunday as first day of week (0 - 6)
    %W – Week of year as decimal number, with Monday as first day of week (00 - 53)
    %x – Date representation for current locale
    %X – Time representation for current locale
    %y – Year without century, as decimal number (00 - 99)
    %Y – Year with century, as decimal number
    %z – Time-zone name
    %Z – Time-zone abbreviation
    News-related:
    %g – newsgroups
    Character-related:
    %% – %
    \n – newline (that is, move the text following these characters to a new line)
    Direct access to headers
    %:Headername: (e.g. "Using %:useragent:, %n wrote:")
    

    If nothing there works, you're probably out of luck.

    I thought I would be able to fix it having read this suggestions, but I was not able to find a German locale file, which I could fix, if there is a similar problem as mentioned for the Polish file. I simply didn't find such a locale file, so I was not able to check if I could adjust something there.

    The standalone Opera Mail client was missing most locales I think. However, if you use Opera Mail that's built into Opera 12, there should be more locale files in the installation directory somewhere. However, I don't think they'll help with the date. You can check though.

    If you do decide to use Opera Mail in Opera 12, you'll need to goto "advanced -> programs" in settings and set https and http to open with the default browser or the specific browser you want.

  • @burnout426 Thank you so much! Thanks to your response I was able to find the specific line and could insert the missing "day of the month" key. In fact it was missing in the accounts.ini for replies. Unbelievable. Solved after years waiting for an update and after Opera Mail was discontinued many hours trying every now and then to search for a solution. You are at least my hero of the month! Thank you again and have a great day!

Log in to reply