Opera Mail - message date formatting problem

  • I noticed recently that there is a problem with formatting the date in the displayed message - date / time of the message is displayed correctly - I have something like this (Saturday and August in Polish):

    "sobota, 23 sierpień 2014 12:12:45.08.2014,"

    The string is badly formatted and when I reply to the message, the header is incomplete (no day number in the date):

    "W dniu .08.2014 o 12:12 Someone example@someone.com pisze:"

    Is there any way to avoid this problem? 😞

  • Is there any way to avoid this problem?

    What locale are you using in Opera (alt + p -> general tab)?

    What locale are you using in your Windows?

    Opera handles things automatically based on those.

    Download the Opera 12.17 installer, launch it, click "options", change "install path" to a folder on your desktop, set "install for" to "Standalone Installation (USB)". In your normal Opera mail, hit ctrl + s on the message to save it as an mbs file. Then, in the standalone installation, goto "Menu -> settings -> import and export -> import mail -> import generic mbox -> add mbox" and import the mbs file. Then, see if the problem exists there too or not.

    Is there any way to avoid this problem?

    You can close down Opera Mail and edit accounts.ini in the "mail" folder. Under the section for each account you want to tweak, edit the Reply= and or the Forward= lines to format the reply header text the way you want. See http://www.opera.com/help/tutorials/mail/advanced/#custom-reply for more info on what you can do. You might be able to format things in a way that avoids the problem.

    Besides that, not sure what else you can do? Does it happen with all messages or just certain ones with messed up date headers?

  • Thanks!

    Yesterday I discovered the cause - first of all - badly translated locale file (Polish). I fixed this file (missing / mixed date and time variables) and then edited accounts.ini. Now everything is OK.

  • Glad you got it working!

  • Hej sumerland, mógłbyś udostępnić te zmienione i poprawione pliki?
    Bo ja edytowałem plik tłumaczenia dodając %d w odpowiednie brakujące miejsca, ale nie wiem co edytować w accounts.ini.
    Ten błąd mnie denerwuje już długo i nie wiedziałem co z tym zrobić.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.