Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Address/Search bar doesn't work, won't let me enter, grays out text, etc

  • I fixed it by recovering opera and when updating it again. After this opera's search is working. To do that you need to go to Menu>Update&Recovery..
    I hope it will fix it for you too.

  • I did nothing and now it occurs much less often. 1 in 10 attempts greys out. I can confirm that focusing in/out and reloading the new tab helps, but the problem is still there.

  • I have same problem on two pc's. It first occurred yesterday on both Operas of latest version: star typing address - click Enter - nothing. New tab - type - Enter - goes ok. Every 1 of 10 or kinda.

  • Same problem. I can't go without Opera it, I will see if I start using the GX for now.


    EDIT: Now that I see you have an update. Apparently, now it's back up and running. (72.0.3815.207)

  • Interesting, similar problem here today - dev stream 74.0.3862.0. Alt-tabbing to another app and back to Opera seems help.

  • @leocg the same thing for me. Opera version 72.0.3815.207

  • @Swollward if you see this problem, just press F5 button. After that you may enter text as usual. That is a workaround. I hope, that Opera will fix it soon.

  • Yeah... Even with 72.0.3815.207, the bug came back.

  • Same problem for me, started happpening to me yesterday during the evening! What's bug is causing this I wonder....

  • Noticed this today. It began just before I updated the browser. Just updated to 72.0.3815.207 and it's still happening. If type a word or a url and press enter, the search or going to the website doesn't work. Using control/enter makes is go.

    Just tested before sending this. Hmm, earlier it'd take me to Google results, now it's adding .com and taking me to websites.

    Windows 10.

  • OK! I'm glad I'm not losing my mind since this is happening on both of my machines now. The Refresh work-around seems to work every time, but man it is really annoying.

  • Same problem here, I noticed it about a day or two ago. I've finally figured out, initially it seemed it was doing it after more than 3 tabs were open. Spent the past hour trying to search and figure it out. I just did an update to 72.0.3815.207 and now it's doing it regardless of the number of tabs open. The only way around it is to type in the full search, cut it, and then do a paste and go. Other wise, just hitting enter, get nothing-no suggestions, no search, nada. Also, it seems(could be wrong it seems kind of random) it's fine if it's a tab that's already been open and used. But when you open a new tab, it won't work.

  • I have the same exact issue. Ever since this new opera update, it has been constantly doing this to me. Seems random on the exact times it lets me enter or not. Sometimes it will take seconds, other times minutes. I really hope this bug gets fixed soon.

  • Have the same issue on 2 browsers. It completely destroys how I use the browser. When the text grey out, I cannot even open pages or search using search bar. Please fix it.
    Opera version: 72.0.3815.207

  • Same issue for me since this morning. Thought it was a bad update or something, updated to latest still the same.

    Especially interesting that known URLs seem to work, only when we venture into "unknown" territory it does not work any more, and also no google suggestions show up (which maybe is related?).

  • I have the same issue, although there is a workaround for me.

    It works at least for me wenn u take the automatic focus of the searchbar when opening a new tab.
    For me atleast it even works when anywhere else on the screen and then back into the searchbar.

    It makes Opera useable again but still extremly annoying.

  • Version : 72.0.3815.207

    Same thing here. Search bar grays out after a very short while once I've typed anything in it. It also seems to only happens when I'm on speed dial ?

    Switching to another tab seems to fix it... until it grays out again.

  • Same here. Open new tab, F5 and then it works. But it is terribly slowing the process.

  • Same problem with 72.0.3815.207.

    Open tab, writing on omnibox, is grayed out text and there's no dropdown with history or suggestions... Pressing enter does nothing. It works one in ~20 attempts by opening a new tab.

    At least the F5 hack works, but this needs to be fixed asap...

  • @namero999 Good workaround at least ... better than copy-pasting stuff from some notepad or something 🙂