Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

69.0.3686.49 on Linux Mint 20: post-installation script error exit status 1

  • Hey guys! The latest Opera came from the PPA today and while the update seems to have worked (the browser runs and says it's up to date, version number is 69.0.3686.49), Synaptic and the command line provide this error message:

    E: opera-stable: installed opera-stable package post-installation script subprocess returned error exit status 1
    

    Subsequent attempts to install updates on my system always throw up this same error message.

    alt text

    I even uninstalled Opera and then reinstalled it from a freshly downloaded .deb file, but the error persists.

    What's happening? Any way to fix it?

  • Hi,
    I kinda solve it with this procedure:
    sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old     
    sudo mkdir /var/lib/dpkg/info             
    sudo apt-get update && sudo apt-get -f install
    sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old    
    sudo rm -rf /var/lib/dpkg/info             
    sudo mv /var/lib/dpkg/info_old /var/lib/dpkg/info

    I mean kinda because anytime there will be a opera update you will need to do it again. But at least it doesn't replay the error everytime you install any app update.
    If you find any better and definitive solution let me know.

  • Ohhh, I've been meaning to respond here, but then got sidetracked. I did find a solution; it's outlined in this thread:
    https://askubuntu.com/questions/438345/how-to-remove-install-a-package-that-is-not-fully-installed

    The accepted answer suggested to comment out all the contents of /var/lib/dpkg/info/[package_name].postinst, but I just went sledgehammer and nuked the file (well, I moved it out of the directory).

    Afterwards, the problem was gone.

    Edit : re-reading your post more closely, it looks like we're both implementing the same solution. I'll keep my eyes open for this issue cropping back up! If it does, perhaps making a script will at least alleviate the hassle of fixing it.

  • I am running Linux Mint 20 Cinnamon, too. I found this thread a week, or so ago for the same issue. I deleted the opera-stable.postinst file then and the issue was abated.

    I just got an update for Opera and after installing it the error reappeared. So, I deleted the opera-stable.postinst file again.

    Any information on actually fixing the actual issue? Is it Opera, LM20, dpkg, or what?

    Thanks,

  • Just upgraded Mint 19.3 to 20. Usual bumps in the road along the way, including this one. My install of Opera Browser failed, but a whole lot of things appeared to go well, prior to the fail, so I went into /usr/bin looking for the file, and there sat "opera" all nice and ready to allow executing as a program, in the permissions department.

    Ok, fine. Double click it, and yeah, Opera (latest version: 70.0.3728.133, all nice and up-to-date) opens up, but it Immediately invokes a download. Hmm.

    Ok, fine. Let's click it again. Same thing. Ok, fine, let's go look at the Downloads folder, and, weirdly enough, there sits a brand-new, just-got-downloaded file named: "opera" and not only that, you can also find "opera(1)" "opera(2)" and "opera(as many as you might feel like creating by double-clicking on the executeable file in /usr/bin). Hmm. Running the executeable "opera" from within /usr/bin does this weird download of "opera" Every. Single. Time. And every single time, a new number gets incremented.

    So. Me being me, I figure what the hell, we're just playing around with this thing anyway, so I remove all of the incremented copies in Downloads and then go ahead and double-click on the initial member of the cascade "opera" without any increment numbers after it and by golly, it works, and it works just as well as the file that's over where it belongs in /usr/bin does, and actually it works better because, yeah, it also does that stupid download thing (nope, I have no idea, I have not delved into it yet, this has all just happened and I'm reporting it on the fly), except that, for reasons unknown, when it goes to download yet another copy of the "opera" file in to the Downloads folder, it does not increment, but instead it simply overwrites.

    So. No Sorcerer's Apprentice. No endlessly incremented copies of the thing. Just nice new ones with nice new timestamps indicating that they're overwriting the previous ones, and golly gee whiz it sure would be nice to know what the hell's actually going on here, except that I don't, but for now, I have a functioning Opera Browser in my Linux Box, and it even absorbed and implemented all my saved settings for Opera from good old Mint 19.3 which this working copy of Mint 20 that I'm speaking to you from was upgraded from.

    Not only that, I'm also speaking to you from the weird-ass "opera," and since I couldn't seem to get it on my menu, I just went ahead and created a link to the copy of "opera" that's in the Downloads folder, and put the link on the desktop, and I'm writing these words, using that Opera Browser that comes up when I hit the desktop link file.

    Does any of this make any sense? Noooooooo, of course not! But it works! And since I like the built-in pseudo-vpn that Opera has, I get to keep on being pseudo-anonymous whenever I feel like it, by clicking on that goofy link on the desktop, 'cause like I said just a minute ago, "it works!"

    Make of any of this what you will, but if you go digging around in /usr/bin and find a file named "opera" then go ahead and run it, look for your brand-new copy of "opera" in Downloads, shut the running copy of the Browser off, and then march right on over to your Downloads folder, find "opera" in there, and then click that one, and see what happens

    Hopefully you'll get a working Opera Browser, too. Without the Sorcerer's Apprentice issues of endlessly-multiplying incremented copies of copies of copies of ....... yeah, that stuff.

    And if that works, then way cool, and you're in business, and maybe we can all sit back and see if the nice people at Opera Central can make sense of any of this, and maybe later on some time, we won't be creating links to executeable files in our Downloads folder, and instead, just open our Opera Browsers the old-fashioned way, by finding it in the menu, or putting it in the Panel, or whatever you might like best.

    And that's my story, and I'm sticking to it.

    Tra la la.

  • Quick edit re my above. We're using Linux Mint Mate. And somehow the word "immediately" in the second paragraph got scrambled into "ImmwsiTWLY" somehow, so that needs to be taken into account. Ok, that's it, signing off, over and out.

  • @leocg

    A thousand and one thanks!