Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved] Missing dependency

  • Not possible to install " opera-stable_69.0.3686.36_amd64.deb ". " Error: Dependency not available: libgtk-3-0 (>=3.19.12) ". Latest Opera version 68. is fine.
    System Ubuntu 16.04 LTS

  • @anab Is it possible to decrease the requirements for libgtk in the next Opera
    release? I think there are many users who use Opera under Ubuntu 16.04 LTS which is not yet phased out. With a manual update of libgtk we will run into problems with other applications such as Nautilus...

  • @anab It seems to be a Chromium dependency: https://packages.debian.org/sid/chromium

  • @leocg Thanks, will it be fixed by next Opera release or is there something to do on my side?

  • @anab You need to update the library

  • @leocg In the repository the newest libgtk version is 3.0. Can you tell me which library exactly I have to update and where I can get it, please?

  • @anab Do you have version 3.19.12 at least?

  • Same problem here. I have version 3.18.9 and I haven't found a way to update it. Vivaldi is working fine and it's based on Chromium 83.0.4103.119

  • This post is deleted!
  • @leocg I have libgtk version 3.18.9 and Chromium 81.0.4044.138

  • It is not recommended to upgrade gtk3 on Ubuntu (even if doable) because it may render some your applications non working or even break your desktop. Ugrading gtk to 3.19 is a non starter. Not going to kill my system because of opera.

  • @anab Then you need to update it, as it seems.

  • @leocg To all who are interested. The answer in the following post solves the problem for me. GTK upgrade and Opera update without any problem on my side:
    https://askubuntu.com/questions/933010/how-to-upgrade-gtk-3-18-to-3-20-on-ubuntu-16-04#

  • @anab said in [Solved] Missing dependency:

    @leocg To all who are interested. The answer in the following post solves the problem for me. GTK upgrade and Opera update without any problem on my side:
    https://askubuntu.com/questions/933010/how-to-upgrade-gtk-3-18-to-3-20-on-ubuntu-16-04#

    I know that method but it is risky to upgrade gtk3 that's why I didn't post the link here. A lot of it would depend on your DE and the applications you use. Glad that it works out for you. But I have switched to Vivaldi, problem solved (opera is never my main broswer anyway. Firefox is)

  • None of the last 2-3 versions of opera browser for linux can be installed on Ubuntu Xenial(16.04) because the package depends on libgtk-3-0 package of a newer version which is not supported by Xenial. When try to install a newer version of libgtk-3-0, the system returns more messages of such dependency problems (for example packages gir1.2-gtk-3.0, libgail-3-0, libglib2.0.0, libgtk-3-bin, libgtk-3-common must be (of) newer versions which are not supported by Xenial).

    At least if i decide to install the necessary packages, i have to download and install a lot of packages of another debian-based distribution manually (something which is very unsafe/risky).

  • @anab said in [Solved] Missing dependency:

    @leocg To all who are interested. The answer in the following post solves the problem for me. GTK upgrade and Opera update without any problem on my side:
    https://askubuntu.com/questions/933010/how-to-upgrade-gtk-3-18-to-3-20-on-ubuntu-16-04#

    This doesn't work for me - there is no highlight background/text on the menus, desktop, windows and text (as well as the menus' lists and icons become graphically too dense) after installing packages from ppa:gnome3-team/gnome3-staging

    It seems there is nothing to do but install a newer version of Ubuntu or another linux distribution.

    Any other suggestions?

  • @vbnvbn said in [Solved] Missing dependency:

    It seems there is nothing to do but install a newer version of Ubuntu or another linux distribution.

    Any other suggestions?

    Yes, there is another way.

    You can download the .deb, right click and extract it with file roller like you do with any archive (instead of installing it) then extract data.tar.xz with file roller, then in the terminal run

    /path/to/opera-stable_69.0.3686.57_amd64/usr/bin/opera
    

    Opera starts here and seems working, I went to Youtube and checked my email, went to a few random sites, so maybe libgtk 3.19 is not really needed to run opera, just a packaging requirement. But I haven't tested it much, like I said I have switched to Vivaldi.

    If it complains about missing libraries in the terminal type (or just do it anyway in case you are missing something but opera still starts)

    ldd  /path/to/opera-stable_69.0.3686.57_amd64/usr/bin/opera
    

    and install whatever libs that are "not found" in the output.

    I got this error when starting opera in the terminal

    ERROR:child_thread_impl.cc(792)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    

    Seems to be related to glibc https://forums.opera.com/topic/38293/solved-opera-66-0-3515-72-1-crashing-without-any-extension-or-new-installation/49, but opera doesn't crash on me, everything is working normally, so maybe it is harmless (though I haven't tested too much, there may be use cases where it is important, and I missed them I don't know)

    If everything works you can make a .desktop file and manually update everytime (replace the folder with a new one) I can't be bother with it myself, but yeah, looks like it can be done

    EDIT: Ok, the error is harmless. I started opera in Ubuntu 20.04 and get the same error but everything there works fine.

  • Ok, after the test above to run opera locally I am pretty sure that libgtk319 is not needed to run opera, it is just a packaging requirement. So for those who want to install opera69 in Ubuntu 16.04 you can just edit the debian control file to fix the libgtk3 requirement and then rebuild the deb. Here are the steps:

    create a directory for editing and rebuilding the opera deb

    mkdir opera_build
    

    Download opera-stable_69.0.3686.57_amd64.deb and put it in the opera_build directory created above

    cd opera_build
    
    mkdir tmp
    
    dpkg-deb -x opera-stable_69.0.3686.57_amd64.deb tmp
    
    dpkg-deb --control opera-stable_69.0.3686.57_amd64.deb tmp/DEBIAN
    
    

    This extracts the debian metadata in opera_build/tmp/DEBIAN, in it there is a control file

    now edit the control file (still in opera_build)

    gedit tmp/DEBIAN/control
    
    

    change the requirement libgtk-3-0(>=3.19.12) to libgtk-3-0(>=3,18.9), then save.

    Now rebuild the deb (still in the opera_build directory)

    dpkg -b tmp opera-stable_69.0.3686.57_fixed_amd64.deb
    

    this creates a new deb called opera-stable_69.0.3686.57_fixed_amd64.deb

    now you can install this like you would normally with a deb and it no longer complains about libgtk3 version. Now when the pop up window comes up asking you if you want to update opera with rest of system, uncheck it, since next time there is an update you would need to go through this whole exercise again, apt upgrade will fail.

  • there is a typo in the post above. temp should be tmp in the last two lines of codes.

  • @kmod Fixed.

Log in to reply