Opera no longer works on Library of Congress site

  • There used to be a forum section for sites that don't support Opera. Don't see it now so I'm posting here. The Library of Congress site used to work just fine with Opera. Haven't gone to it for ages, but now it's unresponsive. Nothing happens when I click links. I tried using right-click menu, Open link in new tab. The selected link doesn't open in the new tab-- Instead, a clone of the page opens. Tried site with Internet Explorer & it performs as it should. Just a FYI. Let me know if there's something else I should do

    LOC link: http://www.loc.gov/

  • Works fine here. If you're still using the Presto build you might want to try masking and see if that helps.

  • Using v. 22.0.1471.70. I'm totally embarrassed, but can't find or remember where I can set masking. Have used it in the recent past-- argh!

  • Sometimes clearing out the cache clears up problems with web sites not loading properly. I tried the site on both the current version of Opera and version 12.16 - no problems on either one. Security programs and extensions can also interfere sometimes.

  • Thanks hitanykey! Clearing cache did the trick!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.