Empty placeholders in opera mail

  • Opera mail worked for years but now placeholders for Subjects and From are empty. I.e. when I start opera it:

    • loads mails from its database,
    • mail counts seem ok,
    • list of boxes placeholders for Subject and From looks normal at first,
    • but after any scroll up/down or click all these placeholders become empty (blank).
      It seems like all mail entries are there except there is no text - just empty placeholders.

    Is there something I could try except deleting .opera/mail ?

    The reason why I am reluctant to delete .opera/mail is that I would like to save mails from sent folder which are not saved on the imap server. (Such mails unfortunately exist because of some other bug.)

    Also, is there a way to backup label definitions ?

  • This is an IMAP account, so Opera should be getting information from the server. If you click on a message to read it, does it show the correct data in the message fields?

  • Right click on a message and choose "view all headers and message". Are the headers there at least? If so, I think Opera's database is just messed up. (The database duplicates some info from the stored mbs file and uses that copy of the info.)

    You can run a database check to see if it fixes it.

    If that doesn't work, try deleting .opera/sessions/autosave.win. If that doesn't work, try renaming .opera/operaprefs.ini. If that doesn't work, you can try reinstalling Opera over the top of itself to repair program files.

    If none of that works, you'll probably have to start over with a new mail folder. To do that, you'd right-click "All Messages/Sent" and export it to an mbs file. Then, goto "Menu -> settings -> import and export -> export Opera contacts. Then, you'd close down Opera and delete the "mail" folder (or rename it so you have a copy of it). Then, you'd start Opera back up and set up the IMAP account again. Then, you'd goto "Menu -> settings -> import and export -> import mail -> import generic mbox -> add mbox", set the mbs file in the "move to sent" drop-down and import into a new account. Then, you'd drag the sent messages in that account to the IMAP sent folder view under the IMAP account's you@example.com access point. That'll upload them to the sent folder. Then, on the IMAP tab in the account's properties, make sure you set your sent folder so that "All Messages/Sent" and the IMAP sent folder are synced.

    If you have feeds too, you can goto "Menu -> settings -> import and export -> export feed list" to export your subscriptions to an opml file. Then, after you set up the new mail folder, you can import that list back in and set each feed's update interval again (if you changed it before). Already-fetched feed messages that are no longer on the feed page will be lost though.

    Then, you'd import your contacts.

    Is there a way to backup label definitions.

    Labels and their rules are defined in index.ini in the mail folder. You can copy them from an old index.ini and paste them into a new index.ini while Opera is closed. Before you paste them into the newer index.ini though, you have to change their index numbers to follow the consecutiveness of the ones already there. You also have to make sure that none of the label indexes you're pasting have an ID the conflicts with the an existing ID in the new file.

    After you do that, you just have to change the index count at the top of index.ini to reflect the new number of indexes.

    If the "autofilter" folder in the old mail folder isn't empty, copy that into the new mail folder (it contains learned rules (if any) for labels in index.ini).

    Just note that while index.ini contains the rules for labels, it doesn't contain what messages go in each label. So, if you manually placed any messages in a label, you'll have to placed them in there again.

    For IMAP specifically, save this page and load it locally to see how to use keywords to save labels that don't make use of rules.

  • Thanks for answers.

    This is an IMAP account, so Opera should be getting information from the server. If you click on a message to read it, does it show the correct data in the message fields?

    After opera restart, the window looks normal - it shows correctly body of the mail where the cursor is in the list of subjects. If I click on some other mail in the list of mails/subjects, this subjects becomes selected (blue color) but subject text becomes invisible and the message body becomes "No message selected".

    Right click on a message and choose "view all headers and message". Are the headers there at least? If so, I think Opera's database is just messed up. (The database duplicates some info from the stored mbs file and uses that copy of the info.)

    It works on the mail where the cursor was immediately after opera restart. Also if I click on mail B and return on mail A then it will not work again on mail A.

    You can run a database check to see if it fixes it.

    Recovery log says database consistent. (BTW the link you mentioned doesn't work for me, I used this one.)

    If that doesn't work, try deleting .opera/sessions/autosave.win. If that doesn't work, try renaming .opera/operaprefs.ini. If that doesn't work, you can try reinstalling Opera over the top of itself to repair program files.

    Tried it but it doesn't work.

    If none of that works, you'll probably have to start over with a new mail folder. To do that, you'd right-click "All Messages/Sent" and export it to an mbs file.

    It asks to download missing bodies before exporting. I click Yes but nothing happens.

  • BTW the link you mentioned doesn't work for me

    Oops. My fault. This one should work. But, yeah, the info is in that other thread you mentioned.

    It asks to download missing bodies before exporting. I click Yes but nothing happens.

    Opera doesn't automatically initiate the export after you tell it to fetch all the bodies. You have to try the export again.

  • Opera doesn't automatically initiate the export after you tell it to fetch all the bodies. You have to try the export again.

    Thanks for the answer. I try, but it always asks the same thing again.

    Also when I right click on a mail in a list of subjects, the "Fetch Complete Message" is gray.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.