Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can only download one attachment per session in yahoo mail

  • I had the same problem for so long, I bought new computer. Now it's the same on my new computer. For me I just fixed mine just now.
    Chrome-settings-Privacy and security - automatic download
    (Block automatic download after first file) - Yahoo mail was there being blocked. I remove the block, and it works so far.
    Hope this will help.
    Hope it stays fixed.

  • Thank you for the information, tomcha. I never knew such a setting even existed in Chrome. I haven't had a problem with multiple downloads in Yahoo mail when using Chrome, but I was hoping your tip might help me with Opera. Unfortunately, I can't find a similar setting in Opera - if anyone knows of such a setting, it sure seems like that would be the answer!

  • @tomcha It works! Thanks. 🙂

  • @era043 Unfortunately, I can't find a similar setting in Opera - if anyone knows of such a setting, it sure seems like that would be the answer!

    I found the setting in Opera and it seems to fix the problem.
    Settings > Advanced > Privacy and Security > Site Settings > Automatic Downloads.
    I found that there was a block for Gmail. I turned on "Ask when a site tries to download ...." and the block disappeared.

    It now works.! Thanks, @tomcha!

  • Ad-blocker already turned off.

  • @tomcha Not ad blocker. If you follow my steps, (I missed to state one step) see below.
    Chrome-settings-Privacy and security - Site Settings - automatic download
    That's where I see the Yahoo Email was blocked for Automatic Download. Once I unblocked it. it works fine.

  • @jimihendricks FANTASTIC!

  • @jimihendricks Awesome job finding the setting in Opera - the fix works for me! Thanks to both you and @tomcha (for figuring out the problem in Chrome). SO glad to be able to use Opera for my Yahoo email again! 🙂

  • Hello everybody,
    I follow this thread the last couple of months, having the same exact problem with Opera and yahoo.mail,
    I did almost everything i read in here, except the "reset profile" thing, with no success...The problem persisted in all my machines (2 desktops, 1 laptop).
    Until... a couple days ago, i read about the "jimihendricks" 's solution...
    I thought, i would try it the soonest, but because i was busy at the time, i didn't do it right away...
    Yesterday, when i remembered it, and before trying the fix, i checked once again (in my laptop, at home) with yahoo.mail in Opera and...It was fixed...!!!! Without me having to do anything...!!!
    And today, the same happened in the office's pc...!! How strange is that?
    Did they release an update, maybe...?? because, i had already make all the updates before...
    I just wanted to share...
    Than you all again, for your contributions!!

  • @nickfrag That's great, @nickfrag! After I followed jimihendrick's steps, I went to do the same on another laptop, but noticed that on laptop #2, yahoo mail had not been blocked in Opera. I wonder what it was that turned "on" the block on my primary laptop in the first place...

  • @tomcha 10x a lot, solved. 🙂

  • @jimihendricks

    Finally someone figured it out. i stopped using opera Long Ago because of this...incredible no one at opera reads these forums and answers these or has this info in the help file.

    so better yet go into privacy and security and under automatic downloads and add Gmail .Com

    why on EARTH opera would have this by default is infuriating.....you want peeps to use your browser....why annoy hundreds of millions of gmail users by not letting them download attachments.

  • @wadebuck My sentiment also. These geeks who design these browser are sometimes out of touch with the reality of regular consumers who just want to the browser to work normally. If we want extra layers of security then it should be up to us to make the effort. I spent so much time trying to solve this downloading bug. Thx for everyone who figure it out.