Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

High cpu usage watching youtube

  • @zalex108 said in High cpu usage watching youtube:

    Animated icon is unnecessary, a toggle to a Static one for those with the problem is more than enough until find a global fix

    Sure.
    But I just suggested a compromise in case if they (Opera) want to keep the equalizer view (jumping bars) to be different from other browsers. I'm pretty sure that very few users will notice the difference or will be against the simple animation,
    *Vivaldi also has an animated tab's indicator (sound waves) but this is just a simple loop animation and doesn't consume CPU.

  • @andrew84

    Yes,
    Options to fix it, exists.
    I don't know the reasons for this situation.

  • By the way, I don't use Opera GX, but there was a report also regarding the new feature 'Dynamic audio visualizer' which also consumes CPU https://forums.opera.com/post/224782
    The feature can be turned off there, but the implementation of such feature tells me that they don't care much for fixing the bug (looks a bit funny because GX offers some RAM and CPU limitations and at the same time GX itself contains feature which consumes a lot of CPU. If I limit CPU usage, the feature will lag, I guess)

  • The Opera 72 update and cleaning out my laptop (both physically & through software) seem to have fixed this issue for me. i have a feeling hardware decoding for video wasn't being used correctly, even though I have a kaby lake CPU

    On MacOS 10.15.7

  • @nintendork07

    Good!

    I did twice here on Win x64 months ago, still the same on them.

    I'll see for V72.

  • For me, problem persist in v.72, Win8.1, fanless i5 CPU, power consumption jumps from 9W to 14W if favicon is animated on youtube vs cursor hover over tab:

    opera_favicon.png

    (Using Open Hardware Monitor to show temp. and power consumption)

  • @marjang I'm also on Win 8.1 but have a weaker/older CPU (integrated graphics) and results are similar - by the cursor hovered tab eats almost 10W less in CPUID HWMonitor.
    2020-10-24_002106.png

  • The main reason I believe this is occurring is because hardware accelerated video decode is not working correctly. Turning hardware acceleration off and then on again seems to fix this for me. I can tell if it's working by how long youtube videos take to load or how high my fans spin (on a simple 1080p youtube video...)

    Another step I used was looking at Opera://GPU and seeing the Hardware Video Decode status.

    For me it said:

    Hardware Protected Video Decode: Unavailable
    Metal: Disabled (I am on Mac)

    I changed the Flag: Override software rendering list and now it says my hardware protected video decode is enabled.

    This is occurring on other chromium based browsers as well (Chrome & Brave)

    I am on MacOS 10.15.7 with Macbook Pro 13 inch 2017

  • Actually i watch videos now sometimes i thaugt some bugs not fix when refresh no bugs i still consufused and some websites loads very slow some are opened but not seenimage Eg:

  • Maybe problem is related to win8.1 ? I can't reproduce on win10.

  • CPU usage is not as high as before, but it is still way higher than Chrome's on YouTube. While watching the same video, Opera gets consistent 30% CPU usage, while Chrome only 8~10%. Disabling audio tab animation does nothing to change this.

    I really like Opera, the look and feel is amazing, but I'm not using it as my main browser until it's solved for good.

  • Problem persist in v.73, maybe it is not as critical as it was, but still too much for fanless CPUs!

    This time i measure about +40% higher cpu power consumption with favicon animation.

    Spec: win8.1, fanless i5 (4570T) cpu, internal gpu.

  • Hi,

    You can try this workarounds in the meantime.

  • Is there any info that Opera is aware of this performance bug?
    It looks like the main problem here is that Opera (developers or Opera management) doesn't consider it's an issue.

  • @andrew84

    Since seems mostly related to W7, with "ended support", It seems it has no attention to be fixed, even to give an option to disable it, at least from Flags.

    It seems to affect also on W8.1 too and even on Mac, but...

  • @zalex108
    That problem stays here for more then 2 years now, over many generations and versions of Opera, regardless which Windows version is used.

    I switched hardware in the last years (Intel to AMD CPU, older to newer AMD GPU), still the same. Windows 10 Pro all the time.

    Firefox does use way less CPU in general for that task and also makes no difference between with sound and muted tab.

    All that combined looks weird for Opera.

  • @fragger911

    Is unusable for those with the problem since Media is mostly everywhere, even without the ability to stop AutoPlay and not always you use or watch in FullScreen.

    The Workaround about change between WorkSpaces, for daily use, it's annoying.

    If it's not fixed even for W10, then... 🙄

  • I may have found a fix.

    For me, Twitch was using about 30% of my CPU per screen. I'm not going to go into detail or lay out my specs but I did find a way to fix my problem.

    1. Make sure hardware acceleration is enabled or this won't work
      (If you can't find hardware acc, go here opera://settings and type in "hardware acceleration")
    2. Go to opera://flags/#ignore-gpu-blocklist
      Enable that setting, relaunch and you should be good.

    I think someone above already answered this but I was unable to find this setting using their instructions.

    I really hope this helps cause I've been having to stress over this for about 2 weeks and it feels good to be back at minimal CPU usage.

  • @gamedevchrs No, problem persist for me in v.75.

    It still goes to about +40% higher cpu power consumption with favicon animation compared to mouse cursor hover on tab.

    Spec: win8.1, fanless cpu i5 4570T, internal gpu.

  • Hi @marjang, first of all go to "opera:flags#disable-accelerated-video-decode" and make sure it's set to "Disabled", and if not disable it, restart the browser and check if it helps.
    Also, you can enable "opera:flags#enable-gpu-rasterization" (don't forget to restart the browser to make it works).

    In addition to the above, check if running the Opera with the following switches (add them at the end of the shortcut which you use to run Opera): "Path\to\launcher.exe" --disable-gpu-driver-bug-workarounds --num-raster-threads=4 --use-gl=desktop
    improves all over performance of the browser (including this playing videos).

    Small note: in case "--use-gl=desktop" makes some artifacts (causes displaying issues in the browser UI), remove it and try to run the Opera with the other switches only.