Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • pls help me with notifications (in windows 10 opera )I am unable to receive them even after subscribing/enabling / allowing them

  • Make sure you didn't enable the opera://flags/#toolkit-bookmarks flag as that might break notifications on some sites.

  • I have seen, it's set on default suggest something else

  • Goto the URL opera://settings/content/notifications. Make sure "ask before sending" is enabled and make sure the sites in question on in the allowed list. I know you said you enabled/allowed them, but make sure on that settings page.

    Disable all your extensions to see if one is causing the issue.

    Do you use Opera Sync?

    Download the Opera installer launch it, click "options", set "install path" to a folder named "Opera Test" on your desktop, set "install for" to "standalone installation", uncheck "import data from default browser" and install. Test in that Opera but don't enable Opera Sync and don't install any extensions.

    Do notifications work fine there? If not, what sites so we can test?

  • checked it "ask before sending" is enabled and sites are in the allowed list
    I don't use opera sync. and trying ur suggestion and will reach soon with the result to u

  • @shrey I managed to fix my notification issue it involved me uninstalling opera with user data and then installing the setup from another browser make sure to go to the websites and enable notifications.

  • Hello,
    If notifications are not coming then do the following.
    1.Open setting then content then notification then allow as per requirements.
    2. Reset the default settings in the setting tab.
    3. Update the system.
    4.Dowoload the latest version of opera.
    David Jack