Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 63 will not run with Anti-virus program

  • I am trying to assist a friend with a problem with Opera 63 failing to open, when used in conjunction with Anti-virus programs (except Windows Defender). He generally uses AVG Free edition, but the same symptoms existed when AVG was substituted with Avast and then Bitdefender.

    He has used Opera Browser for windows since Version 12 or before (I have used it continuously since version 3). The problem started about 1 month ago. It cannot be tied down to a specific change of software or Windows update. System: Dell Optiplex 3010 desktop running Windows10 1903 64 Bit

    symptoms.
    On starting the PC everything appears normal, antivirus starts with Windows 10. Opera will open and operate normally. If closed down it may open again normally several times. Then it will not open. Windows 10 Task Manager shows opera starting and a Crash Report.
    Windows Event Viewer shows no specific problem. At the same time the installed anti-virus program becomes unresponsive. If the computer is rebooted (or re-started) the same symptom may re-occur or both programs will be unresponsive on start-up.

    It has also been noticed that sometimes, when this occurs the Cortana search bar also becomes unresponsive and the pc is a little slower. After waiting for 5+ minutes these items may return to normal but may again be unresponsive when used.

    Attempts at correction.

    1. Uninstall the Antivirus - this is usually successful - Opera works again with Windows Defender alone installed.
    2. Changing the Antivirus program - this does not work the same symptoms persist with alternative AV programs.
    3. Repair or reinstalling Opera - does not work with AV program installed.
    4. Clean Installations of Both programs - i.e. all parts of Opera and AV removed including the Opera stable profile etc. and the Registry cleared of ALL pertinent keys, values and Data - This did not work.
    5. As 4 above installed from Safe mode.
    6. use a clean install of an older Version of Opera V.60 - This did not work as it immediately updated and then failed (Please Opera give us the option not to update, if only for testing)
    7. Finally - Re-install the C-Drive from an Image, with Windows 10 1903 (when First upgraded) -This unexpectedly failed. Opera updated immediately and failed to operate as above despite an older version of AVG installed, which I deliberately did not update. I also stopped Windows from updating the Virgin 1903 upgrade.

    Both programs had co-existed under Windows 10 1903 previously.

    ANY suggestions welcome.

  • @p-h-f said in Opera 63 will not run with Anti-virus program:

    1. use a clean install of an older Version of Opera V.60 - This did not work as it immediately updated and then failed (Please Opera give us the option not to update, if only for testing)

    If you call the installer with a certain switch and then later Opera itself, an automatic update can be prevented.

    Details.

  • @p-h-f I think in a first step I would install the current Opera version in portable mode ["Stand-alone installation (USB)"], parallel to the existing one, and check if the problems with it also occur.

  • You can get older versions from https://ftp.opera.com/ftp/pub/opera/desktop/ if you want. Just download the 64-bit installer for each.

    You can then create a folder on the desktop named "Test".

    Then, open the Windows Task Manager and have it ready.

    Then, for each installer, launch it, click "options", set "install path" to "C:\Users\theusername\Desktop\Test\Opera theversion", set "install for" to "standalone installation", uncheck "import data from default browser" and install.

    Then, as soon as Opera opens where you can see it's close button, click the X and immediately kill the opera autoupdate process in the task manager if it had a chance to run.

    Then, go into the Opera's install folder and rename opera_autoupdate.exe in the version folder.

    That will prevent updating and will allow you to test a bunch of Opera's with fresh profiles without interfering with the default Opera.

    Or, if you want, you can run each of those installers with the command-line switches to make them standalone installations that don't launch automatically. Then, you can delete each of their updaters before Opera ever starts.

    See https://www.reddit.com/r/operabrowser/comments/9snae4/installer_command_line_switches/.

  • @p-h-f said in Opera 63 will not run with Anti-virus program:

    Bitdefender

    Bitdefender (and Sandboxie) have been known to mess with Opera. For Sandboxie at least, you can sometimes work around problems by passing --no-sandbox to launcher.exe. Not a workaround exactly, but something you can test. You can try --disable-gpu too if you think it's a GPU hardware acceleration issue.

    Try in Opera Developer too though. Maybe it's a bug that's already been fixed.

    Test in Vivaldi too as it usually behaves similar to Opera just to see if Vivaldi has the problem too. Test in the latest snapshot at https://vivaldi.com/blog/snapshots/ too.

    In Avast/AVG, try turning off and web shield stuff to see if it makes a difference. Anything that tries to filter/scan contain on pages in browsers. Try just normal scanning and real-time scanning to see if that changes anything.

    Changing the Antivirus program - this does not work the same symptoms persist with alternative AV programs.

    The Cortana issues persist too?

  • @burnout426 Thank you for your quick replies. I had totally forgotten about the command line switches. Not used since Opera 15 or before. Sandbox is disabled by default on his PC. I may try Opera Developer, but I have searched for similar reports and not found another, so think it is unique to his computer. I am not sure if the Cortana issues arose with other AV programs, it was not noticed until the re-install of AVG. I will try your suggestions and those of @yanta. Again thank you for your quick replies. I think I am in for the long haul to resolve this issue.

  • @yanta Thank you for your replies I will try your suggestions.

Log in to reply