Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

mailto protocol

  • Each time Opera updates itself is deletes the setting for my mailto protocol

  • Are you talking about the setting in opera://settings/handlers where mailto was there and the updated removes it? If so, was it set to default (click the 3 dots to the right of it to see what I mean)?

    Or, are you talking about the system mailto setting or both? What OS? What version of Opera? Did you have Opera set as the default mailto handler along with "mailto" listed in handlers in Opera with it set to default?

    Or, was some other program set as the mailto handler in the system and Opera is stealing it and setting it to itself?

  • @burnout426 Talking about system mailto setting only, Windows 7 Pro, latest version of Opera. This happens every time Opera updates.

  • @bbildman Could you explain more on what you mean about Opera deleting the system setting? Are you saying that the "mailto" protocol goes missing in Default Programs? Or, are you saying it's set to Thunderbird for example and when Opera updates it reverts back to some other program or no program? Or, are you saying Opera sets itself as the default mailto program? Or, are you saying "mailto" is not longer listed in the "set defaults by protocol" list? If so, how do you get it back?

  • @burnout426 After Opera update, the Windows Live Mail mailto protocol is unclicked, and I have to go into Control Panel default programs and click it. Also, when there is an update, the PDF default becomes Opera instead of Acrobat. Obviously there is something going on there when updated.

  • @bbildman Thanks for the clarifications. I'll see if I can figure out anything.

  • Opera doesn't change mailto and pdf of me when updating, but..

    Do you have Opera installed for the current user only ("C:\Users\username\AppData\Local\Programs\Opera") or all users ("C:\Program Files\Opera")?

    You could, uninstall Opera while keeping your data, delete Opera's program files directory if it's still there, clear Opera stuff from "C:\windows\temp" and "C:\Users\yourusername\AppData\local\temp" and delete any leftover autoupdate tasks for Opera in the Windows Task scheduler. Then, you could launch the instaler, click "options" and choose not to make Opera the default browser (do it later in Windows after the install).

    However, you might be able to just rename/delete installation_status.json in Opera's program files directory.

    If Opera still does it on you, then there might be a bug.

    If necessary, you could delete "mailto" from "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaStable\Capabilities\UrlAssociations" and delete pdf from "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\OperaStable\Capabilities\FileAssociations". Do the same for the OperaStable key in "HKEY_CURRENT_USER\Software\Clients\StartMenuInternet". Then, hopefully, the update process doesn't add those back in (but it might).

  • @burnout426 I appreciate your input, but for me it's easier to just open control panel and revert the setting than to jump through all the hoops you mentioned.

  • @burnout426 said in mailto protocol:

    However, you might be able to just rename/delete installation_status.json in Opera's program files directory.

    Try just that.

Log in to reply