Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]External devices and Opera

  • I have just started using Opera on my Ubuntu 16.4 laptop, and mostly I love it. However I find that it does not seem to recognise devices connected to my computer, but not integral to it. This prevents me, for example, loading an image held on a USB drive to an email I'm writing, or printing an attachment I've received without first downloading it to my hard drive and then opening it in another application to print it.

    Is there any switch in Opera that will permit this access? as I have not been able to find any way of doing this and other browsers have no such problems. Any help would be greatly appreciated.

  • Opera doesn't allow you to open a file without downloading it first.

  • Let me guess. You are using the snap version of opera, right?
    Snap apps have permissions on what they can and can not access, like android apps do, so please check what permissions has your system given to opera.

    Or, just be reasonable and install the regular deb version of it.

  • @leocg The problem is, I can only download to the computer's hard drive. I cannot download to an attached USB drive. The same applies to uploading.

  • Don't know about Linux but on Windows you can download to any drive/device recognized by the OS.

  • Can you please answer my question, is it the snap version of opera or not? If you do not know, tell us how you installed it.

  • @jimunderscorep I don't know if it is the "snap" version. I downloaded from the ubuntu software library.

    The help.About screen says:
    Version:60.0.3255.83
    Opera is up to date
    Update stream:Stable
    System:Ubuntu Core 16 (x86_64; Unity)

  • @leocg My version does not download or upload from any drive apart from the internal hard drive of my computer. Nautilus, Unity's version of File Manager shows all connected drives, but if I use Opera, I have to download to the hard drive, then use Nautilus to copy to USB, or copy from USB to the hard drive to upload.

  • It's the snap version then. As I said above, snap apps have permissions on what they are allowed to access on the os, because they operate in (something like) a sandbox.
    Read more here and enable filesystem permission for opera if you wish to keep the snap version
    https://www.omgubuntu.co.uk/2018/07/snap-app-permissions-manager

    Sorry, I could not find a page that explains it better.

  • @jimunderscorep Thank you for your help so far.

    I found the permissions in the software store. I tried to make changes and entered my password when asked however when I closed the permissions, nothing had changed. When I re-opened it, everything had reverted to as it was before. I still cannot access anything outside my home. directory.

    I have tried attaching files from USB sticks with the permissions still open. Re-installing opera and changing the permissions before running it. Every time, the permissions refuse to change permanently for my installation. Is there anything else I can try?

  • Well, there is only one solution remaining then. Remove the snap version of opera and install the deb one, like most of us do.

  • @jimunderscorep Thank you for your help. I installed from the Opera website, and it's looking good so far.

Log in to reply