Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flashplayer not working

  • @sgfdhsg , sometimes it is useful to clear browsing data. Navigate to opera://settings/clearBrowserData and check "Content settings" in Advanced tab. This helped me to make Flash working.

  • @zibi1981 Something to note: snap sandboxes apps (and therefore Opera, if installed via snap) to their own little folder inside snap on the root of the drive. This means that Opera cannot interact with Flash, as it is NOT installed in Opera's snap. That's why --no-sandbox fixes it: Opera can find Flash as it is not restricted to their own little space. At least, I think that's how it works.

  • Hello guys

    Using Opera in the Deepin Manjar or Deeplin ArcLinux occurs the same situation. Adobe flash player plugins do not work on Opera, Google Chrome and Vivaldi

    Browsers that are running at the moment without any problem are Firefox and Chromium

    Adobe flash player and pepperflash are in their most recent version, being 32.0.0.207.1

    Does anyone have any tips on how to reestablish the functionality of adobe flash player in Opera using the Distros mentioned above?

    Follow some Opera images on some sites that have the plugin available and do not work.

    [img]https://i.imgur.com/OBQTAT2.png[/img]

    [img]https://i.imgur.com/6EVUQXT.png[/img]

    [img]https://i.imgur.com/6EVUQXT.png[/img]

    Your Considerations

    Edson

  • Linux developers and owners of browsers need to understand that the novice and novice user, when browsing any page, wants the adobe flash player application to work until the date of its definitive closure. The application is still active and many web pages contain the plugin. What to do for this people to understand this (!?)

  • @pindos Thank you, I tried, nothing changed...

    Today I updated the flash to 32.0.0.207 but no change....

  • @edsonmartim
    There is not such thing as deepin manjaro or deepin arch.
    Are you on deepin, which is debian based, or in manjaro, which is arch based?
    If you are on something that is arch based, ppapi (pepper) flash plugin malfunction is related to the bug that loup001 said at the first messages of the topic.

    I agree for the second part, but allow me to post an experience I had last year. For some reason and for a couple of days, my firefox was failing to play html5 streams and it was falling back to flash when it was available. The browser's performance was so awful that once I got it to play the streams as html5, I immidiately disabled flash so as I won't deal with that crappy performance again.

  • I have a "similar", but a "different" problem. Flash player is installed and is detectable, but it doesn't work only in Opera. As you guys can see in the screenshots below, the same websites working fine in Chrome (on left side) and the problem occurring on Opera (on right side). So... this is a BIG question mark, it just doesn't make sense. I hope somebody can help me. Thank you in advance.
    PS: Twitch.tv never asked me to allow Flash Player to watch it in Chrome, I don't why Opera just doesn't work.

    alt text
    alt text

  • @Lotts First, Chrome has its own built-in Flash, so Chrome isn't exactly the best browser to compare with when talking about Flash. It would be better to compare with another Chromium based browser like Vivaldi, for example.

    One thing you could (and should) try is going to opera://settings/content/flash and isable Flash. Main serious sites don't need it anymore.

  • Adding to the above, twitch uses a combination of flash, for the player, and html5 (h264), for the stream, so do not use it to judge opera if you do not have chromium ffmpeg codecs installed and working, at the very least.

    And the above reason is the one I have never watched twitch inside a browser, because, let's be honest, that flash + html5 combination is trash.

    Also, are you on snap opera or on the deb one? This is a trick question that will trigger a lot of other answers 😛

  • @leocg I can't do that since I use some websites that uses Flash.

    @jimunderscorep Chrome was working for the majority of websites that I visit, but a few was problematic and it didn't work properly, so I had to switch between Chrome and Firefox everytime I wanted to visit a specific website. I installed chromium ffmpeg via snap and now Chrome is working 100%. I want to migrate to Opera, though... Just to try something new.

    I downloaded Opera on the official website which is the deb version.

  • @Lotts Those sites know that Flash is going to disappear, right?

  • @leocg Yeah... But I can do nothing since they're using it yet :/. I don't know what they'll do in the future, but probably they'll use Flash until it's no longer possible.

  • @Lotts Did you already try to use those sites with Flash blocked? I remember have seen some sites that asked for Flash if it's available but if you had it blocked, they used HTML5.

  • @leocg Yeah, it doesn't work.

    Screenshot with Flash blocked:

    alt text

  • Please remind me again what distro you are on. Ubuntu? If so, do you have chromium ffmpec codecs installed?
    The black box on twitch.tv is because of opera's poor codec support, h264 in this case. I have the same one here.

    2019-06-14-180923_1280x1024_scrot.png

    On the other window, with the flash elements... no idea. But flash works for me as seen above

  • @jimunderscorep Yes, Ubuntu 19.04. Yes, I did install chromium ffmpec codecs today via snap (sudo snap install chromium-ffmpeg).

  • Let's get some things straight...

    Snap apps and regular (apps you install via deb, apt, etc) apps are 2 different things.
    Snap apps come as a set with all their libraries and run in a sandboxed enviroment. They also have permissions on what they can and can not access, e.g. external storage.
    Regular apps are like... the ones we were using all these years, e.g. they share libraries, they are installed system wide, they have access to other libraries installed seperately (e.g. flash) and many more.

    When you install opera as a snap app, you must also install chromium ffmpeg codecs as snap, because snap opera "links" to the ffmpeg codecs snap. Also, there is no flash if you install opera as a snap, because snap apps are sandboxed and do not have access to other libraries of the system.

    When you install opera as a regular app, you must also install chromium ffmpeg codecs via apt or something similar, because the regular opera will look for the regular ffmpeg codecs, And because it has access to other libraries in the system, it will also use flash if it is installed.

    So, first things first. Remove the snap opera and the snap version of ffmpeg codecs. Second, make sure you have opera installed from the deb package and chromium ffmpeg codecs installed. Third, make sure you also have flash installed. Do all that and come back if you still have issues.

  • @jimunderscorep I'll try my best here but it might be not understandable because English is not my first language.

    When I installed Opera, I did install it as a regular app (.deb from official website). But with your last reply I realized that the version of Flash that was installed was the 32 bit, so I removed it and installed the 64 bit one. Then I removed chromium ffmpeg codecs from Snap since I installed Opera as a regular app.
    When I tried to install chromium ffmpeg codecs with apt, I got this: "chromium-codecs-ffmpeg-extra is already the newest version (74.0.3729.169-0ubuntu0.19.04.1)" so it was already installed before I install Opera.

    So basically:

    Opera is installed as a regular app;
    Chromium ffmpeg codecs was already installed;
    Flash now is installed correctly.

    But I got the same error.

    I tried this, though:

    1 - Remove Opera as a regular app;
    2 - Install Opera and chromium ffmpeg codecs with Snap;

    The result was: (predictable since it was the Snap version and you told me that a Snap app is run sandboxed)

    Twitch.tv worked fine, but here (https://helpx.adobe.com/br/flash-player.html) Flash was undetectable and websites that uses Flash didn't work (there was a green button telling "Install Flash").

  • How can you tell you installed the 32bit version of flash? It takes some "effort" to install any 32bit lib or app at a 64bit system.
    Basically, how did you install flash originally?

    Hint: the output of
    dpkg -l | grep flash
    may somehow help us.

  • @jimunderscorep I found on a brazilian website that using it (sudo apt-get install flashplugin-installer) was the 32 bit version and it (sudo apt-get install adobe-flashplugin) was the 64-bit. But when I used the above command, I could see thats not correct. Anyway, neither works.

    That's the output of dpkg -l | grep flash:

    https://pastebin.com/raw/F7RaiSGR

Log in to reply