Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Dark Reader extension doesn't work on google.com with Opera

  • @leocg could you please link me to a source for that?

    The reason I think it was Opera doing the sniffing is because it logs this message in the dev console:

    Opera has modified script or content on www.google.ca (PATCH-1269, Hide Chrome ad from Google pages). See browser.js for details
    

    Stylish on Opera also gets this error when trying to load a custom CSS on google.com:

    Could not communicat­e with the page. Try reloading the tab.
    Stylus can access file:// URLs only if you enable the correspond­ing checkbox for Stylus extension on chrome://extensions page

  • Source of what? If you are talking about Google deliberately making their pages to work differently in browsers other than Chrome, I guess Google itself could be your source.

    Also, Chrome extensions are made to work in Chrome and may not work at all in other browsers, even on the ones based on Chromium.

  • browser.js probably modifies the content of several pages where the extension works, so I don't think it's the cause of the issue. browser.js is a resource usually used as a last option to fix problematic pages.

  • Hello, I'm Dark Reader developer.

    Just opened Opera today and the extension worked on Google Search page. It stopped working on Google Search after the Opera update.

    p.s.: Something is wrong with percent calculations during the update 🙂

  • @alexanderby hey thanks for confirming the problem with the update, and also thanks for your work on Dark Reader. I'm impressed how far it has come from the early days... even difficult sites look like they have a native dark theme now. It's gotten so good at handling all websites I frequently use that I don't even need to use Stylish anymore

    I wasn't going to wait around for Opera to fix (or decide not to fix) their issue, and I don't want to work without dark pages, so I switched to Chrome yesterday... it's been a smooth transition, the only thing I really missed are keyboard shortcuts, but found an extension to solve that 🙂

  • @dtgq I think this same issue is what is causing Proper MenuBar to break

  • Try enabling 'Allow access to search page results' in the extension settings.

  • Lovely idea, @leocg. Worked for me. Thank you

  • @leocg Worked, thanks! Thought it was a regression, but was just a new feature... anyway, goodbye again Chrome, back to Opera!

  • Topic closed as solved.

Log in to reply