Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Colors messed up when hardware acceleration enabled

  • Hello everyone!

    Recently I encountered a problem with colors in Opera browser, please see the screenshot below. Everything is working fine though if I disable hardware acceleration.

    This problem started after I set up a custom ICC color profile. Even if I revert back to the old color profile, I still have this problem if hardware acceleration is enabled. I tried reinstalling Opera (without purging the config files) but that did not help.

    I'm using Opera 56.0.3051.104, the OS is Debian stable 9.6 and the machine is Thinkpad x201

    Any help on how I could enable hardware acceleration and still have normal colors will be much appreciated 🙂

    qq

  • What gpu are you on?

  • Standard integrated Intel graphics

  • Can you use chrome://flags/#force-color-profile to force sRGB?

  • I tried your suggestion but the changes I make do not persist. After I restart the browser it is back to default.

  • @reacan said in Colors messed up when hardware acceleration enabled:

    I tried your suggestion but the changes I make do not persist.

    Does the change fix the issue until you restart at least? Or, are you saying it doesn't do anything and you can't tell if it does something after a restart because it gets reverted on you?

  • When I changed the setting to sRGB Opera told me that "Your changes will take effect the next time you relaunch Opera.", after I relaunched Opera the setting was back to default.

    However this issue is no longer an issue, apparently one of the updates fixed it and I can enable hardware acceleration once again. Thank you guys for looking into this and trying to help 🙂

  • Topic closed as solved.

Locked