How to stop auto search submission in 12.16

  • Hi,

    When doing a search of page text, the browser will start the search before the search query is fully entered. This makes the browser hang, for example, when it is trying to do a search for a single letter in a large text file before it has been told to run the search. I remember that in older versions it didn't do this. How can I return it to this behavior? I can't find anything about this in opera:config or online.

    Thanks

  • Tried this:

    opera:config#UserPrefs|ShowSearchSuggestionsInAddressfieldDropdown

    Highlight and choose Go to web address. Clear the checkbox, scroll down to click on Save. Restart Opera.

  • Not address bar search suggestions, but searches of the page text, like when you press Ctrl-F. The browser tries to search the document from the moment the first character is typed into the search field, even though that's not the full string that the user is searching for, and it causes some hanging when it happens in large documents.

  • This happens since Opera 10.50.

    I suggested them to add a 1 second or 500 ms delay between entering keystrokes and actually searching in the past:
    http://my.opera.com/community/forums/topic.dml?id=473431

    I don't have a slow computer to reproduce the issue anymore though...

  • Originally posted by rafaelluik:

    I don't have a slow computer to reproduce the issue anymore though...

    You don't need a slow computer, just open a large page. I agree something like a 500ms delay or an enter press, whichever comes first, would be better.

    (But you can always get a slow computer through a virtual machine.)

  • Oh, I see, I thought it was a lot newer. Guess I didn't notice for a while. Maybe there'll be an option eventually. Thanks. 😃

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.