Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Colored background showing in text/search fields

  • Using each version of 56b (Win 10, 1803). I'm finding in many forms (but not most search fields) that the field highlights with a colored background as I type, or highlights the whole field if I click right after the last letter entered. It's typically blue but it depends on the site. To get rid of it while typing, I have to click in the text, but when I start typing again it comes back. And it stays that way, covering the whole of what I typed, often even if I delete the typed text. I'd post a screenshot, but they don't pick it up. I tried other browsers on the same sites and it's only happening with Opera. The only significant change I made around the same time as 56b first showed was updating to the latest Windows version from the previous one. Is there something in Opera, such as new a setting or new feature that's causing this, or could it be coming from a Windows setting somewhere? Besides being a distraction, on some sites it makes entering information a lot harder.

    For example, it happened here (which is a search field): http://www.btmon.com/
    Or here, when filling in one's choice of time: http://www.timezoneconverte...

  • Here's a screen recording of the second example: https://1drv.ms/u/s!AqsCKHVTj0ydmwjzQd_8kMunPyYB

  • 0_1538531186168_odd.png

    Pretty annoying and other times when I am typing it is highlighting what I type in blue,

  • Since upgrade last night to v56.0.3051.36 on my Win 8, 64 Bit PC I immediately spotted a problem on one of my regular sites, not yet seen on other sites. Been using the site ADVFN, uk.advfn.com for many years with many different browsers and versions.

    Their BB site (password access) has plain black text on a white background, the text entry/edit box is normally a simple black frame on the white background, entered text is normal black on white same as rest of BB. Opera v56 now shows body of this edit box in a light blue colour, with a band of darker blue at bottom (or top). Entered text now comes up as black on a darker blue background, like selected text. Moving cursor away changes text to black on the light blue background, like deselected. Resuming entry brings back 'Text Selected' dark blue background to text. Text selection applied inside box results in inverted text, white text on blue background, outside edit box selection is normal black text with dark blue background. After posting, the message appears normally. This blue shading to text also now appears in other text entry boxes on the site.

    Also inconsistent across site. Sometimes the edit box has darker blue band at top, sometimes at bottom. Sometimes even seen 'normal' plain white background, though entered text still appears 'Selected'.

  • Steady as she goes! Looks like I may have found a fix.

    Under Settings:Browser:Advanced:System: 'Use hardware acceleration when available'

    This was ON, changing to OFF and tapping 'Relaunch' button seems to have cleared the issue.

    Anyone have a likely explanation? First signs of growing hardware incompatibilities with Opera?

  • I noticed this too, some text boxes are getting darker when the mouse is hovering over a menu of hyperlinks. I just updated to Win10 october update and figure this also might have something todo with it?

  • @xpvb48 This fixes it. I think we have to wait for nvidia to update drivers for windows 10 october update.

  • Hi @xpvb48, you can try the following: re-enable hardware acceleration, go to opera:flags#force-color-profile, and select "sRGB" from the drop-down, then press "Relaunch now" button, and see if this helps.

  • @l33t4opera fyi, this does not fix it for me.

  • Hi @joostmeij, and when you try one of the other options from the drop-down list, does it help?

  • @l33t4opera Nope, none of them work. I have W10 october update also installed on a Surface Pro 1 and are experincing the same issues. So it's probably not related to nvidia's display driver..

  • @l33t4opera said in Text problems with Opera 56:

    Hi @xpvb48, you can try the following: re-enable hardware acceleration, go to opera:flags#force-color-profile, and select "sRGB" from the drop-down, then press "Relaunch now" button, and see if this helps.

    Thanks l33t4opera,

    Tried that didn't work, same as before. I don't know if any of the other force-color-profile settings would help.

    My Win 8, 64 Bit laptop uses Intel HD Graphics hardware with driver ver 9.17.10.3040 which I tried to update via the MS Update Driver button and it didn't find any newer. Perhaps I can get something direct from Intel Support. In the meanwhile the solution for my machine still seems to be to turn off hardware acceleration.

  • @joostmeij, @xpvb48 Maybe instead of completely disabling HW, you can try to launch the Opera with one of the following switches: "\path\to\launcher.exe" --disable-direct-composition or --disable-gpu-compositing , and if it helps, add appropriate switch at the end of the shortcut, which you use to run the Opera - of course as a workaround, until the time it will be fixed either in new version of the driver for your graphics card, or in the Chromium/Opera's code.

  • I have the same issue

  • Did both versions of recovery, nothing, I also uninstalled and reinstalled, same thing.

  • @leocg all that does is reload this thread.

  • It points to my previous post. Now you read it again and do what you forgot to do.

  • Windows 10 64-bit with Opera 56.0.3051.36 64-bit, if I goto https://gamefaqs.gamespot.com/boards/234547-super-smash-bros-ultimate/77067417, log in and click "post new message", I get the message editor. But, mine looks fine and the text field is all white. It doesn't have gray strips at the top and bottom.

    Can you type anywhere in there? As in, is it just messed up look-wise? I can't tell from the pic.

    What happens if you open a private window, and try things there? Do you have any extensions? If so, disable them to see if one is causing the problem.