Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

youtube: your browser does not currently recognize any of the video formats available (continued)


  • After a recent auto software update, this issue reared it's ugly head again with a pretty nasty plot.
    My last post on the matter mentioning to copy libffmpeg.so from /usr/lib/chromium-browser has been invalidated and no longer works, but I can't edit the post here to state that:
    https://forums.opera.com/post/146297
    (sorry to the unlucky people who google that thread just to potentially give me a dislike)

    I'd done some research to see what wasn't supported, and found that 2 of the most popular codecs were missing in action:

    like who TF doesn't use H.264 ಠ_ಠ

    so after running my patch mentioned above, all seems well and good:

    but unfortunately it turned out to be far worse:

    I'd double checked to make sure I was using the latest libffmpeg.so from chromium, and even reinstalled the thing entirely just to make sure...
    but despite my efforts, nothing worked... -.-*

    This is a good joke Opera devs, please get serious soon.
    This should've been strenuously tested before the update release was even made.

  • @leocg I see...
    forgive me for sounding so harsh.

    sounds like someone else needs to pull their heads out of their butts then, because this is ridiculous.

  • @tcll5850 It's not Opera's fault and there isn't much that they can do.

  • @leocg right, it's a number of dumb actions:

    • the legal restrictions on H.264
    • google's recent practices

    sorry, I didn't mean to make that last post sound like it was the Opera devs. 🙂
    (your reference post perfectly explains it's beyond them)

  • Hi @tcll5850, try to add this repo, and install/update the "chromium-codecs-ffmpeg-extra" package, or download it from here, and install it using dpkg -i *deb. If it still not working, try additional steps: navigate to the Opera's installation root, add a new subfolder "lib_extra", and make there a symbolic link to the lib as follows: ln -s /usr/lib/chromium-browser/libffmpeg.so.

  • @l33t4opera oh that worked, big thanks for the help 🙂
    wouda never've guessed my last chromium repo went stale >.>

  • @tcll5850 You're welcome;-) I'm glad that this works for you.

  • Topic closed as solved. If in up until to a month the author needs the thread to be reopened, just report it. briefly explaining the reason.

Log in to reply