Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Unable to start video on some websites

  • I wonder how am I intended to click "Click to enable Adobe Flash Player" on some websites. Exceptions seems doesn't work or am I intended to add every CDN networks and subdomain website utilizes ?0_1530863658761_Opera 0_1530863691338_Opera Snapshot_2018-07-06_105431_settings.png 0_1530863724704_Opera Snapshot_2018-07-06_105509_settings.png

    Thanks In advance for any help

  • If you have "allow sites to run flash" set, you shouldn't need any 'allow' exceptions at all.

    Also, while chrome://flags/#flash-detection-through-navigator-pluginsis supposed to help with Flash player detection, sometimes it can break sites. Try turning it off to see if it helps.

    If that doesn't work, you can try this extension to see if it helps. It will act like "Allow sites to run Flash" even when "Ask first" is set. In addition though, it'll unhide tiny Flash objects so you don't get "plug-in blocked" notifications in the address field where you have to unblock them.

  • Thanks a lot. Disabling flash-detection-through-navigator-plugins helps on some sites but only in normal mode. And for some reason in private mode video still not loading.
    Also on at least one website video still not loading in opera or chromium. Although works well in firefox. URL for example:

    The site uses the following video tag:

    <video id="html5player" style="" poster="//" tabindex="0" data-src="" src="blob:" autoplay=""></video>

    ( Sorry did not find any "code' tag )
    Is opera able to run this kind of video tags? I mean mpd and/or blob ?

  • Hi @coderaiser, if you don't mind, what's your Linux distro?
    In case it's Debian/Ubuntu based, you can install/update one of the ffmpeg packages from the link mentioned here, and if not, you can download it, and extract the file to /usr/lib/chromium-browser, or /usr/lib/chromium-browser/libs, and see if it helps in your case.

  • Thanks a lot. It's fedora 28 and missed package is chromium-libs-media-freeworld from rpmfusion repo

    Thanks again. Now everything works perfectly

  • When I tested latest stable, the ffmpeg preload still wasn't working when is placed in opera/lib_extra dir, but not sure if the ubuntu install of the lib will be loaded or not. If not,
    ln -sf /usr/lib/chromium-browser/,
    -run in opera install dir.
    v68 of the lib works as well as v67.

  • Topic closed as solved. If in up until to a month the author needs the thread to be reopened, just report it. briefly explaining the reason