Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Newest version of Opera won't remember passwords

  • I lost a lot of time understanding why Dashlane extension was no longer working on Opera (on Mac OS 10.11): due to the automatic update of Opera and its version 53 which cuts the communication between Dashlane and its plugin (via the extension "Install Chrome Extensions")! So I found (with difficulty) on the Web how to disable this automatic update: -auto-update-on-osx, then reloaded version 52 which solves the problem. I am surprised that an update of Opera is incompatible with an add-on as important and popular as Dashlane. I think I can not no more wasting so much time in case of new bug so annoying and I will change broswer.

  • So, because of one change to a certificate, that means that Opera needs access to the keychain forever? I cannot stay logged in to anything any more unless the password is in the keychain?
    That is pretty crazy. None of my other browsers behaves that way, since persistent cookies work fine.

  • @concretable said in Newest version of Opera won't remember passwords:

    So, because of one change to a certificate, that means that Opera needs access to the keychain forever?

    Only to its own Keychain item that it put there itself, the Opera Safe Storage. Opera doesn't have access to any other Keychain items.

    I cannot stay logged in to anything any more unless the password is in the keychain?

    The password is not in the keychain - it saves an encryption key in the keychain that is used to encrypt your cookies.

    That is pretty crazy. None of my other browsers behaves that way, since persistent cookies work fine.

    All Chromium-based browsers behave this way.

    There is more information available in this blog post as well:

  • @mgeffro No 3rd party software.

    Re. catching issues. Certainly, not everything will be caught. But major ones such as this should be easy to find:

    • People simply restart after an update (that they may not even have known was performed
    • Upon restart, they are asked their Opera Keychain password
    • They didn't know there is such a thing as Opera keychain or didn't have their password handy so skip the step

    To me, that is really basic stuff. I'd always test what I thought people might do, and the shortcuts they might try to make. I would never only test the simple basic script as many people will not be able to or simply will not stick to it.

    If you need someone to train your testers, I'd be more than happy to. This is the kind of bad release that can cause lasting damage and should be avoided at all costs.

  • Same problem here. I skipped the keychain as I couldn't figure out what is was asking and opera is now very much less usable. Closed down opera and restarted to get the question back but that did not work. How do I go back to the all-important question about keychain access? Uninstall, perhaps?

  • @albrt if you denied Keychain Access at first time it should actually ask again next time Opera is started.

    1. Make sure Opera is not running (quit it using Command+Q) and open Keychain Access (Applications -> Utilities -> Keychain Access)
    2. In the search field, enter "opera safe storage" to find Opera's keychain item
    3. Open "Opera Safe Storage" and switch to the tab "Access Control"
    4. Under "Always allow access by these applications", click the '+' button and browse to where you've installed Opera. Do this even if the list already contains Opera.
    5. Close Keychain Access and open Opera and it should have access to its storage again.
  • @mgeffro 0_1528096864665_Screen Shot 2018-06-04 at 12.14.26 AM.png

    Notice: The + and - signs are greyed out. Nothing to click above there. I commend you for trying, but your people made a screw up of monumental proportions. My offer stands. Opera needs someone to teach their QA people how to test, and I'm willing to do it. Your business could depend on it (if there's much left after this)

  • @acapaloff + and - signs are greyed out cause you have 'Allow all applications to access this item' options checked. This isn't default setting for Opera Safe Storage key. But even with this option set Opera shouldn't have problem with accessing stored passwords as steps mentioned earlier aren't necessary in this case. I tried checking this and so far didn't have any problem with storing passwords and staying logged in to website with this option enabled.

    If you got time to help me investigate this could you tell me few things:

    1. What version of macOS you are using?
    2. Are there any passwords displayed on opera://settings/passwords dialog
    3. Do your problems reproduce with clean profile? You can check this by starting Opera from command line with --user-data-dir=<custom_tmp_dir_path> parameter.
  • @mgeffro A few things:

    My OS version is 10.13.4. I've actually never used a command line on a Mac, and spotlight doesn't recognise it as existing.

    I had previously checked confirm before allowing access and nothing changed.

    Since reading your latest response, I tried it again a number of ways - with and without "Ask for Keychain password", and with only Opera and with Opera and the other browsers I use. The save button doesn't work. When I exit the page, Keychain asks me if I want to save my changes. I click Save. I immediately re-enter Access Control and whatever I entered in there is gone. Wondering if removing then re-installing Opera could work. But honestly, I'm very busy and all the time I've spent on this so far:

    a) would have been better spent doing other things
    b) should never have been necessary because no release this bad should ever go live

  • @acapaloff Found "Terminal", pasted your command, got this response:

    -bash: syntax error near unexpected token `newline'

  • @mgeffro I have done this but it doesn't seem to make any difference. Quiting opera, either with the menu option or with cmd+q, and restarting does not bring up the keychain question. I went into the keychain manually as you suggested. Opera will still not remember passwords. Log in somewhere and it happily asks 'Do you want to safe...' and there is no error message, but it won't recall. Although when quiting Opera and restarting, it is still logged in to the various websites so something is being remembered. I am running 10.13.4, by the way.

  • @Albrt could you try following steps:

    1. Start Terminal application
    2. Run following command in terminal to start Opera
    1. Check Terminal if there are any messages there.

    Hopefully you should have some error messages there that could give us hint on what is going wrong for you.

  • @mgeffro Done this and indeed get errors. I have the following messages


    [2153:84739:0605/] Could not read download entries from file because there was a read failure.
    [2153:47363:0605/] Failed to restore security token.
    [2153:775:0605/] Cache is not initialized, cannot RetrieveEntry.

    followed by heaps of identical messages. Is this useful? It doesn;t tell me which is the file which can't be read.

  • @albrt as the errors indicate that there could be some problems with logging to pages nothing that would point exactly at problems with keychain access. Could you check if you have problems with password when using clean profile:

    1. Start Opera by issuing following command in Terminal
    /Applications/ --user-data-dir=/tmp/opera_clean_profile
    1. Try to save some password
    2. Close Opera
    3. Launch Opera again using above command from Terminal

    If that is the case it would mean your profile got corrupted and there might be no easy way to resolve problems with it. In such case you could try following steps to get it working again. Note though that all of them will delete some data so not sure how willing you are to try them. Will order them from least harmful:

    • use opera://settings/resetOpera page to reset default settings
    • clear data through opera://settings/clearBrowserData
      ** from dropdown choose 'since begining'
      ** from list chose 'Cookies...' and 'Passwords'
    • clear whole profile using Terminal. This step will remove all your data
    rm -rf ~/Library/Application\ Support/com.operasoftware.Opera/
  • @mgeffro I did step 1-4. It recalls usernames but not passwords. Fewer error messages though:

    /Applications/ --user-data-dir=/tmp/opera_clean_profile
    [3634:775:0605/] Not an update at all.

    /Applications/ --user-data-dir=/tmp/opera_clean_profile
    [3703:36355:0605/] Failed to restore security token.

    Does this point at the user profile? Introduced by the recent upgrade? I was wondering why it isn't asking about keychain access. Opera must think it has access but the mac disagrees.

  • @albrt For me it looks like this when using clean profile. After logging on I get following menu under address field:
    After allowing to save password I go to opera://settings/passwords and have password for Netflix visible there:
    What you describe seems to be indeed some problem with Opera Safe Storage in keychain and data stored in profiles.

    If you don't care about saved passwords or any data you have stored in Opera you could do following:

    1. Close Opera
    2. Remove Opera Safe Storage from keychain
    3. Remove profile using terminal rm -rf ~/Library/Application\ Support/com.operasoftware.Opera/
    4. Start Opera

    This will recreate new profile and Opera Safe Storage and should allow to save passwords without problems.

  • idk, i use the latest version of opera and it works for me 😛

  • @cosminplays I am not blaming Opera: this happened most likely because of a mistake I made. But I need to finish a task first so will wait a few days before attempting the fix.

  • @misterarthur I had the same problem. I fixed the password problem by deleting the Opera entry using Keychain Access (I don't save many passwords). After that no more repeated password popups. However, whenever I close and re-open I was being asked to accept cookies.

    For the moment I've uninstalled Opera and will use other browsers for a while. I'll probably give Opera another go in a few months, but clearly the quality on Mac is lacking.

  • @mgeffro It works again. After the update to MacOS 10.13.5, opera restarted asking for access to the keychain, which it had refused before. And after that it recalled passwords, including ones which were saved during the time opera was unable to retrieve them. It seems it did have write access to the keychain.