Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Newest version of Opera won't remember passwords

  • @faisduvelo Opera is only accessing 'Opera Safe Storage' in keychain. It should have no access to other items or break it in any way as it's controlled by your operating system. Could you try checking instructions I've posted above on how to edit 'Opera Safe Storage' keychain access manually?

  • @misterarthur Same problem here. Also can't download any files. Basically, the browser has become mostly useless. Pity, as it had quickly become my favourite browser.

  • @misterarthur I got that prompt. It was the first I knew of an Opera keychain. Once I skipped that step, all passwords were gone and none can be imported from other browswers or saved

  • @mgeffro I closed Opera and restarted it. No prompt. And I was once again signed out of everything. As a QA Analyst and Tester, I would have found these glaring issues and not allowed this release to go live. Basically, Opera is now useless having previously been the best browser out there. Suicide?

  • @acapaloff are you sure you are not using any third part software which does additional check of certificates? We are aware that our certificate change did cause problems with at least 1Password and Little Snitch.

    As for detecting issue and stopping release. Sure we could have handled it better. As QA Analyst you should know better than anyone else that it's not possible to detect all bugs or asses their impact in all cases.

  • @mgeffro You can add Dashlane to the list of third party software that no longer works.

  • Yesterday, I couldn't even find the right password for this and the only option was ESC, destroying keychain use in several application (for example, unable to send iMessages anymore after that). This was tested several times after restarting OSX.
    This morning, I just gave my sessions password and click Always allow and everything seems fine, I can even see Opera's Safe Storage password, which was impossible yesterday... and I am not fool, that password wasn't mine.
    Did nothing except verifying the rights for Opera Safe Storage concerning Everything was correct, so nothing to change. But it works now.

  • I lost a lot of time understanding why Dashlane extension was no longer working on Opera (on Mac OS 10.11): due to the automatic update of Opera and its version 53 which cuts the communication between Dashlane and its plugin (via the extension "Install Chrome Extensions")! So I found (with difficulty) on the Web how to disable this automatic update: -auto-update-on-osx, then reloaded version 52 which solves the problem. I am surprised that an update of Opera is incompatible with an add-on as important and popular as Dashlane. I think I can not no more wasting so much time in case of new bug so annoying and I will change broswer.

  • So, because of one change to a certificate, that means that Opera needs access to the keychain forever? I cannot stay logged in to anything any more unless the password is in the keychain?
    That is pretty crazy. None of my other browsers behaves that way, since persistent cookies work fine.

  • @concretable said in Newest version of Opera won't remember passwords:

    So, because of one change to a certificate, that means that Opera needs access to the keychain forever?

    Only to its own Keychain item that it put there itself, the Opera Safe Storage. Opera doesn't have access to any other Keychain items.

    I cannot stay logged in to anything any more unless the password is in the keychain?

    The password is not in the keychain - it saves an encryption key in the keychain that is used to encrypt your cookies.

    That is pretty crazy. None of my other browsers behaves that way, since persistent cookies work fine.

    All Chromium-based browsers behave this way.

    There is more information available in this blog post as well:

  • @mgeffro No 3rd party software.

    Re. catching issues. Certainly, not everything will be caught. But major ones such as this should be easy to find:

    • People simply restart after an update (that they may not even have known was performed
    • Upon restart, they are asked their Opera Keychain password
    • They didn't know there is such a thing as Opera keychain or didn't have their password handy so skip the step

    To me, that is really basic stuff. I'd always test what I thought people might do, and the shortcuts they might try to make. I would never only test the simple basic script as many people will not be able to or simply will not stick to it.

    If you need someone to train your testers, I'd be more than happy to. This is the kind of bad release that can cause lasting damage and should be avoided at all costs.

  • Same problem here. I skipped the keychain as I couldn't figure out what is was asking and opera is now very much less usable. Closed down opera and restarted to get the question back but that did not work. How do I go back to the all-important question about keychain access? Uninstall, perhaps?

  • @albrt if you denied Keychain Access at first time it should actually ask again next time Opera is started.

    1. Make sure Opera is not running (quit it using Command+Q) and open Keychain Access (Applications -> Utilities -> Keychain Access)
    2. In the search field, enter "opera safe storage" to find Opera's keychain item
    3. Open "Opera Safe Storage" and switch to the tab "Access Control"
    4. Under "Always allow access by these applications", click the '+' button and browse to where you've installed Opera. Do this even if the list already contains Opera.
    5. Close Keychain Access and open Opera and it should have access to its storage again.
  • @mgeffro 0_1528096864665_Screen Shot 2018-06-04 at 12.14.26 AM.png

    Notice: The + and - signs are greyed out. Nothing to click above there. I commend you for trying, but your people made a screw up of monumental proportions. My offer stands. Opera needs someone to teach their QA people how to test, and I'm willing to do it. Your business could depend on it (if there's much left after this)

  • @acapaloff + and - signs are greyed out cause you have 'Allow all applications to access this item' options checked. This isn't default setting for Opera Safe Storage key. But even with this option set Opera shouldn't have problem with accessing stored passwords as steps mentioned earlier aren't necessary in this case. I tried checking this and so far didn't have any problem with storing passwords and staying logged in to website with this option enabled.

    If you got time to help me investigate this could you tell me few things:

    1. What version of macOS you are using?
    2. Are there any passwords displayed on opera://settings/passwords dialog
    3. Do your problems reproduce with clean profile? You can check this by starting Opera from command line with --user-data-dir=<custom_tmp_dir_path> parameter.
  • @mgeffro A few things:

    My OS version is 10.13.4. I've actually never used a command line on a Mac, and spotlight doesn't recognise it as existing.

    I had previously checked confirm before allowing access and nothing changed.

    Since reading your latest response, I tried it again a number of ways - with and without "Ask for Keychain password", and with only Opera and with Opera and the other browsers I use. The save button doesn't work. When I exit the page, Keychain asks me if I want to save my changes. I click Save. I immediately re-enter Access Control and whatever I entered in there is gone. Wondering if removing then re-installing Opera could work. But honestly, I'm very busy and all the time I've spent on this so far:

    a) would have been better spent doing other things
    b) should never have been necessary because no release this bad should ever go live

  • @acapaloff Found "Terminal", pasted your command, got this response:

    -bash: syntax error near unexpected token `newline'

  • @mgeffro I have done this but it doesn't seem to make any difference. Quiting opera, either with the menu option or with cmd+q, and restarting does not bring up the keychain question. I went into the keychain manually as you suggested. Opera will still not remember passwords. Log in somewhere and it happily asks 'Do you want to safe...' and there is no error message, but it won't recall. Although when quiting Opera and restarting, it is still logged in to the various websites so something is being remembered. I am running 10.13.4, by the way.

  • @Albrt could you try following steps:

    1. Start Terminal application
    2. Run following command in terminal to start Opera
    1. Check Terminal if there are any messages there.

    Hopefully you should have some error messages there that could give us hint on what is going wrong for you.

  • @mgeffro Done this and indeed get errors. I have the following messages


    [2153:84739:0605/] Could not read download entries from file because there was a read failure.
    [2153:47363:0605/] Failed to restore security token.
    [2153:775:0605/] Cache is not initialized, cannot RetrieveEntry.

    followed by heaps of identical messages. Is this useful? It doesn;t tell me which is the file which can't be read.

Log in to reply