change to search window

  • Opera switches to google search at random times, usually searching random single letter, does not seem to be connected to mouse activity or anything else, sometimes this is very frequent and frustrating. I am using Ubuntu 14.04lts on an HP 3.5 ghz, 6 processor core amd 64 machine.

  • What desktop (as in, Unity, Gnome, LXDE, etc)?

    Middle-click pasting random text into a page (not into an actual form) will result in Opera trying to go to that site (if it is a web address) or else searching for that text. I'm not sure what might be happening to result in Opera thinking text is being pasted into it, but that is the most likely scenario here.

    You can partially disable it by changing the middle-click options so that Opera enters auto-scroll mode (previously called "panning") if it detects a middle-click instead of pasting ... I'm not certain if (provided it truly is random) auto-scroll would actually be better, but at least it will prove whether it is related to middle-clicking.

    If you hold Shift while middle-clicking, it will bring up the middle-click options dialog, or it can also be accessed through Preferences > Advanced > Shortcuts if you don't have an actual middle button or scroll wheel. Select the option for auto-scroll/panning and see if anything changes.

  • You can add up to 50 "normal" (customized) search entries (plus Hotclick entries), but it's easier to just replace one of existing 17 entries.
    If you don't have a search.ini or an "empty" search.ini, only Google, AllTheWeb?, Super, and Find in page will get listed (that's probably a bug).
    Opera won't add other built-in search engines (like Find in page) automatically if you add more than three search engines to your search.ini (that's probably another bug).The list of Search Engines has to be ascending and must not contain any gaps. If the list is incomplete, all search entries after the last correct one will be missing in all dialogs.
    If some of your Search Engines are listed in the Hotclick dialog and in Preferences but are not displayed on the Personal bar, it's because of missing Key entries.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.