Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Ubuntu-Mate Opera failing to load web pages - possible DNS Issue

  • I upgraded my machine from Ubuntu 14.04 running on a Virtual Box to Ubuntu-Mate 16.04 running native on a new hard drive. I copied my data files across from a backup and reloaded the applications.

    After doing this, Opera is showing my old Bookmarks but it is not able to load a web page when I select one of the bookmarks. It just sits there spinning.

    I have tried removing and purging both "opera" and "opera-stable" and then reinstalling but after every attempted removal with

    sudo dkpg --remove opera
    sudo dkpg --purge opera
    sudo dkpg --remove opera-stable
    sudo dkpg --purge opera-stable

    and a subsequent install using GDebi Package Installer, it keeps coming back with my old bookmarks so I know that the removal was not clean.

    I am attempting to reinstall


    with GDebi Package Installer.

    I know that the issue is with the configuration of Opera on this specific machine because: 1) Firefox works from this machine with no problems, and 2) Opera is working find from a different machine on the same LAN.

    I'm looking for help to either:

    1. Completely remove an existing Opera install including all configuration files, or
    2. Fix whatever is broken in my installation's configuration files.

    Thank you for any help. I've been fighting this for a few weeks on and off.

  • Under /home/<yourhomedir>/.config/
    Just rename opera directory to something else. Then give it a shot.
    It will automatically recreate the opera dir but you can see if it works with the newly created dir.
    Then if you want to give the original directory another try, rename it back to opera after deleting the newly created one.

    First, though you should try opera://settings/clearBrowserData, check every box but passwords and see if that helps. Also leave VPN or Turbo off until you get it working normally.

  • Thank you very much. That worked. All that I had to do was rename the "opera" folder under /home/<yourhomedir>/.config/ and then reinstall with sudo apt-get install opera-stable.

    At this point, it is good to go. Thank you.

  • Topic closed as solved. If in up until to a month the author needs the thread to be reopened, just report it. briefly explaining the reason.