Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Can't open user profile directory, because you lack sufficient privilieges.

  • I have successfully installed opera on all the machines except the last one (Linux Mint 18.3). I did install it but it did not appear in the menu. I tried to fire it up through the terminal. Nothing happened. Then I put sudo ....now it's telling me that I can't open user profile directory because I lack sufficient privileges. I did look for the opera files in the system and changed properties from root to my name.

    I tried to remove it through the synaptic plus the alt-f2 (mate) to eliminate all (complete removal). Shut down and installed again....same problem....any solution? I did install it on another Linux Mint 18.3 machine and it worked ok.

    Thanks for your help.

  • @danbarmt

    I found out that this problem is not only on my pc. Just check here: https://duckduckgo.com/?q=where+is+the+opera+profile+directory+in+linux&t=lm&atb=v24&ia=web

    One user is blaming it on a conflict with Libreoffice. I did compile the latest Libreoffice though. On the other hand, I did use bleachbit to clean my pc but still no positive answer. I still can't use my opera on this machine!!

  • I found out the solution! I installed the opera developer version (52 at the moment). Now it's running ok. I'm a happy penguin!

  • A solution anyway. Developer and Stable should use different profile directories (see About Opera for location) so Developer isn't dealing with the old profile.

    You said you changed ownership of the files, but did you change ownership of the directory?