Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera is not keeping any site logged in

  • To put it simply: It does not matter if I mark the "Keep logged in" check box on any site. as soon as I close and re-open opera, it ask me to log in again.

    I had this problem for some time, in which I had to login every time I accessed google's inbox, even if I checked the keep logged in box. Since I was using 2 google accounts, I tought it was something related to google.

    Last week, it started happening to Deviantart, facebook, twitter, and even my extensions, like Evernote Webclipper.

    I checked some posts here, saying that I should clean my cookies. I did that and the problem stays. (and I let the setting on accept all cookies anyway).
    other posts said to do a clean install. Done that, using Revo Uninstaller to make it thorough. Even installed the stable version (was using beta) and when that failed, tried the developer version. same thing.

    Cleaned every folder named Opera Software, from Appdata local and roaming, both program files folders. reinstalled on a fresh install. same thing keeps happening.

    is there anywhere else I forgot to check?

  • I've the same problem, and I did the same thing to resolve it but nothing :|
    And I don't know why, but some website keep me connected like Instagram or the Nexus (for video games mods).
    And Twitter, Facebook, my google account (Very annoying for youtube) don't keep me connected.

    I've this problem since I've reinstalled Windows (new stuff for my computer) so, the installation was necessarily clean

    If someone have a solution ? I have Opera since 8-9 years and it's the first time I have this :|

  • @toninho3rd
    Are cookies being set by those sites?
    You should be able to see a list of the stored cookies in the Privacy and Security section of the Opera settings.
    I assume you're certain that Opera isn't set there to delete cookies on exit?
    馃檪

  • I am also having the same issue with GMAIL and other sites (but they are not so annoying). The problem occurs with Opera 51 on Windows 10. It does not occur when I go back to Opera 50 on the same machine.

    I deleted *%appdata%\opera software* and that had no effect.
    I reloaded a backup of *%appdata%\opera software* and that had no effect.

    I have moved back to Opera 50 and all is back to normal.

  • I have the same problem. After latest update I notice that.
    For now I dont know how to solve this.

  • I'm having the same issue ever since latest 51 update.... and I have tried everything. Google chrome is doing the same thing to.....

  • @overclockit
    It sounds like a general issue with Chromium then.
    馃檪

  • So clearly, this is general issue on Opera browser..
    i have same issue since update Opera latest version.

  • @davehawley Yep. I'm just lazy about typing all those passwords.

    Ok... So I've tried again. this time, I've installed the latest stable Opera 50 version, following @camhef 's advice.. but it immediately updated to 51 anyway.

    However, I noticed something: It was working fine, with Google Inbox and Deviantart staying logged in, UNTIL I tried to use Opera Sync. for some reason, as soon it synced (and took a bit of time to do it), google stopped being logged in.

  • I've been seeing some reports about that problem but I couldn't reproduce it here.

  • I have the exact same problem. Plus, the gesture for closing at tab doesn't work correctly either.

  • @marv241 The second part is something for another topic.

  • Make sure you have logged outta google 1st..

    disconnect my Google account and clear all data from Opera (both the 32 and 64-bit versions) and either re-install a pristine default Opera or a new default profile Opera should reset everthing and then log back into google.

  • also disable anti virus esp malwarebyes.. (to see if there is a conflict)..

  • @nvmjustagirl

    Nope it just doesn't work. It made it even worse. Now I have to type in the code for 2-Factor Authentication every single time I restart the browser altough cookie settings are fine.

  • I have the same problem for several days after the last update.
    Opera developers, please fix it quickly!

    Recently, the same problem was in Chrome after updating, but it was removed successfully.

  • @campedor92
    If it's been fixed in Chrome, I'm sure it will be fixed in Opera and the other Chromium browsers soon.
    馃檪

  • If the problem is a Setting started on old Synced' data, for those using only "Bookmarks" sync, you can export your Bookmarks and start with a new profile "again".

    Reset Sync data and do the Set Up, import bookmarks, install extensions...

    Could be tedious for some cases but could fix the problem earlier.

    PS:
    Passwords could be exported also enabling the Flag option:

    0_1518278678329_2018-02-10_170404.png


    Windows 10 (x64) | Anniversary Update
    Opera Stable 路 Beta 路 Developer

    Opera Test profile | Opera Reset / Back up LinuxMacWin

  • @zalex108 Doesn't help unfortunately. It doesn't matter whether you use the sync option or not. I personally didn't use the sync option and it didn't work either.

    Theres actually no work around. It's just a bug that got fixed in Chrome but not for Opera right now.

  • Same problem here, but only for some sites, not all of them

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.