VPN is unsupported on your current version of Opera.

  • I have just installed Opera: "45.0.2552.898 - Opera is up to date". I turn on VPN and try to navigate to any webpage. I get the message:

    Browser upgrade required
    VPN is unsupported on your current version of Opera.
    Please upgrade to the newset version of Opera to continue using the VPN service.

    When I click "Download Now", it wants to download the same deb file that I've already got! (opera-stable_45.0.2552.898_i386.deb)

    I'm running Debian GNU/Linux 9.3 (stretch).
    sudo apt update/upgrade/dist-upgrade all tell me that I'm up-to-date.

    How can I fix this? Downloading the same file again seems rather silly...

  • You didn't mention - you are running 32-bit Linux. That's why you are stuck with 45. Opera no longer owns the Easysurf VPN service. New versions of Opera are using Opera's own servers to provide VPN service. I have no idea if they'll issue an update to 45 to fix the issue for 32-bit Linux, but that is what would be required. Until (if) they do, the VPN will no longer work.

  • Ok. That makes sense. Perhaps the error message could say that 32 bit linux is not supported, rather than asking me to download it again?

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.