Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • @yaute The folder named with the version number, inside Widevine's folder located under the browser's profile directory.

  • @leocg what I do :
    āžœ ~/.config/opera# mkdir Widevine
    āžœ ~/.config/opera# cd Widevine
    āžœ ~/.config/opera/Widevine# cp -r ../../chromium/Profile\ 1/File\ System/Plugins/000 .

    I have nothing in opera://components and it doesn't work.


  • @yaute There should be a Widevine folder under Opera's profile directory already.


    Inside of it there should be a folder with Widevine's version number. I'm on Windows but I don't think it is much different in Linux.

  • @leocg Ok, Iwill try with another Linux in a VM.

  • While I don't have Netflix, I did search for Widevine on ElementaryOS. It found the following results....

    This folder is empty but may work for you.

    Contains the manifest.json

    Files found were....
    /usr/lib/x86_64-linux-gnu/opera developer/resources/widevine_config.json

    I'm running Opera version 49.0.2725.39

  • Fyi, opera looks in here for the widevine libraries

    $ cat /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json
    "preload" : "/opt/google/chrome/",
    "plugin" : "/opt/google/chrome/"
    "preload" : "/opt/google/chrome-beta/",
    "plugin" : "/opt/google/chrome-beta/"
    "preload" : "/opt/google/chrome-unstable/",
    "plugin" : "/opt/google/chrome-unstable/"

    And as it seems, all of them are the ones that come with the chrome packages.

  • @minuteman I have no directory WidevineCdm on my arch

    @jimunderscorep I create and copy & manually into /opt/google/chrome and it work !

    thanks guys for your help.

    PS: in opera://components I have always nothing

  • Glad I helped šŸ™‚
    In case anyone of the devs is reading this...

    As we all see from the above, opera expects to find the widevice libs inside chrome's installation path. Why not add the


    path to the above. It is where ubuntu's chromium package installs the same libs. I mean, opera checks for the ppapi flash in various locations in order to find it, so why not look for the widevine libs elsewhere? Editing these files to add the proper path, as far as I know, breaks opera because it somehow checks the "originality" of them and fails to start.

    And all that is just a part of a bigger discussion about customizability, e.g. the default search engines follow the same rules and cause the same problem if their file is altered.

  • Solution to this problem is simple - just turn off Opera Turbo mode. Yeah, it was that easy.

  • @yaute Is this solution still working for you? It worked for me for some time but now it doesn't although I have both files under /opt/google/chrome

  • @yaute didn't work. I am running Manjaro with the latest Opera.
    I mean ffs this issue has been plaguing Opera for years, years and nobody does a thing. Netflix does not work on Opera (Linux) out of the box and this is the only single reason why I don't use this browser. I can understand that Opera does not give a damn for those poor 3% Linux users. But please do invest some of your precious time to write at least a tutorial or howto or am I asking too much?

  • @tastymineraler Same thing with Ubuntu and Majanro here.
    Sometimes i fixed this just putting widevine files on /opt/google/chrome, but did't work now.

    I used Opera 52 on Ubuntu and Opera 51 on Manjaro.

  • @tastymineraler IMHO, any browser that is considered to compete with Chrome or Firefox should be able to play Netflix and other sites with movies. It is a big part of browsers' use nowadays and I cannot imagine a modern browser without that functionality.

    BTW, it works in Vivaldi out of the box.

  • I have the same problem - I think.
    Widevine files ( & widevine- are in /opt/google/chrome, I used this script to install them:

    If I use a user agent switcher, Netflix loads and neither gives me a widevine error nor redirects me to the support site (
    But the problem is that the video is loading forever (
    And it doesn't matter if I have Chrome installed or not, i. e. if there's an additional file, the video will still load forever. The widevine_config.json file is also configured correctly.

    I don't know what I'm doing wrong...
    Any help is appreciated :smiling_face_with_open_mouth_smiling_eyes:

  • Hi, I found a solution, just follow my small how to. šŸ™‚

    1. Put files libwidevinecdm and libwidevinecdmadapter to /opt/google/chrome
      If that folder doesn't exist then create it. If you don't have those files you can
      download them from my googledrive
    2. Install User-Agent Switcher addon and setup it to chome Linux and the highest chrome number
    3. Watch Netflix šŸ™‚
  • Doesn't work for me.
    Netflix gives me this error: .
    To be honest, I think I'm going to switch back to Chrome again, because it just works (+ the sync is better).
    Anyway, thanks for your help šŸ™‚

  • @awesome-nils

    It's strange. I used this solution on 2 laptops and it works.

    1. Did you use the right setup in the point 2?
    2. Do you use also another user agent besides the one mentioned in the point 2? If yes then switch it off.
    3. Check also what you have in the file widevine_config.json. It should be located in /usr/lib/x86_64-linux-gnu/opera/resources
      My file contains
      "preload" : "/opt/google/chrome/",
      "plugin" : "/opt/google/chrome/"
      "preload" : "/opt/google/chrome-beta/",
      "plugin" : "/opt/google/chrome-beta/"
      "preload" : "/opt/google/chrome-unstable/",
      "plugin" : "/opt/google/chrome-unstable/"
  • The link in your post above links only to text/xml.

  • @s390g2 is obsolete anyway on newest versions of browsers. But netflix works out of the box with firefox. With vivaldi, only and - no ua switch needed. Have not tried chromium lately, but a start with --user-agent= something would probably work.
    Newest opera's on linux need some work.

  • @s390g2 said in Opera & Netflix:

    The link in your post above links only to text/xml.

    try this one