Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

UI is laggy - only runs at 60 fps on 144 Hz monitor

  • Re: UI elements are laggy and animate at only 60 fps on 144 Hz monitor.
    This issue is still persistent on the latest version of Opera. The entire UI seems to be capped at 60 fps. I have a 144 Hz and a 240 Hz monitor. All other applications and the Windows desktop animate at the native refresh of the monitor resulting in a super smooth UI. Only Opera's UI feels laggy because it seems to run at 60 fps.

  • What's Vivaldi do? What about its latest snapshot? What about Plain Chromium and its latest trunk build? What about Chrome and Chrome Canary? What's latest Opera Developer (right-hand side of page) do?

    I was wondering if Chrome works fine, but all the other Chromium browsers don't or if even Chrome doesn't work fine.

    I assume Edge and Firefox work fine? Or, are you just saying other applications besides browsers?

  • @burnout426 Edge and Firefox on Windows run their UIs at 240 fps on my 240 Hz monitor. Safari and Firefox on macOS also run at 144 fps when connected to an external 144 Hz monitor. Opera on macOS is also capped at 60 fps. I didn't test other browsers yet.

    The vast majority of other applications also run at the native refresh rate. Electron apps lag, but these don't even run at 60 fps on a 60 Hz monitor. Chromium on its own doesn't lag as much as most Electron apps.

  • Yeah, I'm wondering if it's a Chromium issue more than just an Opera issue.

  • This issue still persists. I tested Chrome and found that the UI elements were smooth, but web pages had laggy scrolling. In Opera both the UI and scrolling are laggy.

  • @kathampy This flag may help scrolling..

    Smooth scrolling

    Speedup the page scrolling the content smoothly

  • Can you give detailed specs on your system? (Including resolution and DPI settings etc.)

  • @burnout426 said in UI is laggy - only runs at 60 fps on 144 Hz monitor:

    Can you give detailed specs on your system? (Including resolution and DPI settings etc.)

    System #1:
    MacBook Pro (15-inch, 2017)
    Radeon Pro 560 4096 MB
    Asus PG278Q (2560x1440 144 Hz, no DPI scaling)
    macOS High Sierra (10.13.4)

    System #2:
    GTX 1080 8GB
    Asus PG278Q (2560x1440 144 Hz, no DPI scaling)
    Asus PG258Q (1920x1080 240 Hz, no DPI scaling)
    Windows 10 (April 2018, 17133.33)

    There is a visible delay when clicking any UI element in Opera, in addition to the UI only animating at 60 fps. In Chrome the delay is lower, but the UI still animates only at 60 fps. However the viewport is able to animate content up to the native refresh rate.

    The UI in Safari, Edge, and Firefox all animate at the native refresh rate, with no click delay.

  • @kathampy Thanks for the info. What about G-SYNC in Nvidia settings? Is that enabled? Does it make a difference if you toggle it? Any similar option for the AMD GPU?

  • @burnout426 said in UI is laggy - only runs at 60 fps on 144 Hz monitor:

    @kathampy Thanks for the info. What about G-SYNC in Nvidia settings? Is that enabled? Does it make a difference if you toggle it? Any similar option for the AMD GPU?

    I leave G-SYNC on all the time. Switching it off doesn't make any difference since it's only enabled for fullscreen applications anyway (the monitor remains in G-SYNC mode, but windowed applications don't affect the refresh rate - if it did the cursor would visibly slow down to the framerate of the application).

    The monitor on the MBP always runs in normal mode without G-SYNC.

  • @kathampy said in UI is laggy - only runs at 60 fps on 144 Hz monitor:

    Asus PG258Q

    And, just for good measure, what are the CPU specs on the devices?

    Dev tested on Asus PG258Q but wasn't able to reproduce the issue. Both Chrome and Opera are working the same and aren't laggy.

  • I assume you have the latest GPU drivers etc., but you can try checking opera://gpu or chrome://gpu to see if anything is disabled.

    You can try turning off hardware acceleration in Opera's settings.

    Also, just to rule out opera://flag settings changes and profile changes etc., download the Opera installer, launch it, click "options", set "install path" to a folder your desktop, set "install for" to "standalone installation" and install. Test in that Opera. For investigation purposes, you could go through some of hte opera://flags settings and enable the GPU blacklist override. You could also try some of the gpu flags in there like rasterization. But, still have a standalone installation with default flags to compare.

  • @burnout426 said in UI is laggy - only runs at 60 fps on 144 Hz monitor:

    @kathampy said in UI is laggy - only runs at 60 fps on 144 Hz monitor:

    Asus PG258Q

    And, just for good measure, what are the CPU specs on the devices?

    Dev tested on Asus PG258Q but wasn't able to reproduce the issue. Both Chrome and Opera are working the same and aren't laggy.

    The MBP has a "2.9 GHz Intel Core i7".
    The Windows PC has an i7 4820K at 4.5 GHz.

    I wouldn't expect someone used to a 60 Hz display to be able to detect the lag. You need a 500+ Hz mouse so the cursor is smooth and clicks are instant, and the desktop should actually be running at 240 fps behind Opera so that you can see the contrasting difference in framerate. You can detect the delay when clicking the + icon to open a new tab. Also, clicking the Telegram icon slides in the window from the side bar at a low framerate.

    The built-in pages like Settings, Extensions, and Personal News have horrendous scroll lag - they barely scroll at 30 fps. You can clearly see the difference in scrolling smoothness compared to Edge / Safari. I'm not sure if this viewport lag is related to the application UI or a separate Blink performance issue. https://testufo.com/ is able to render at 240 fps in the viewport.

  • @kathampy Okay. Thanks for the info. Will let you know.

  • In a dual monitor environment using Windows 10 your monitors have to run at an equal or multiple refresh rate of each other..
    Example - monitor 1 (144hz) monitor 2 (60hz) = You'll need to set your 144hz monitor to 120hz to match your 60hz monitor.

    The only way to run your hardware as it was intended without stutter on one monitor or the other is with Windows 7 and Aero disabled.. *just say 'n..

  • @nvmjustagirl said in UI is laggy - only runs at 60 fps on 144 Hz monitor:

    In a dual monitor environment using Windows 10 your monitors have to run at an equal or multiple refresh rate of each other..
    Example - monitor 1 (144hz) monitor 2 (60hz) = You'll need to set your 144hz monitor to 120hz to match your 60hz monitor.

    The only way to run your hardware as it was intended without stutter on one monitor or the other is with Windows 7 and Aero disabled.. *just say 'n..

    Yes, I've overclocked the HDMI port (headless display which is always on just for audio) going to my AV receiver to 120/144 Hz for my 240 and 144 Hz monitors repsectively. I didn't have stuttering due to the mismatch - I had backlight flicker on the desktop with G-SYNC enabled instead. I don't use the two monitors together, but only either one monitor and the AVR. The AVR does not recognize the overclocked video anymore, but it still plays the audio including bitstreaming for Dolby Atmos etc.

    The problem with Opera isn't stuttering. It's that the main window's UI elements simply do not run at high refresh rates no matter what. The view port is capable of animating content at 240 Hz, but it rarely scrolls that smoothly in real world use. It's way laggier than Safari / Edge and Firefox on both macOS and Windows.

  • @kathampy sorry i assummed you was dual.. thanks for the info..

  • I tried out the new instant search feature on macOS. Again, the whole overlay lags and animates at a low framerate.

  • For some reason, my opera-brower is running at 60hz, whereas my primary monitor runs at 144hz. How can i change this?

    Hardware acceleration is disabled, if that makes a difference. I have the latest opera stable: 52.0.2871.99

    Monitor: Acer XF240H FullHD, 144hz, 1080p CPU: Intel i5-6600 GPU: 2x Rx480 in Crossfire (+Freesync)

    Thank you